Solved

My inbulid webcam not working ?

Posted on 2011-03-13
25
374 Views
Last Modified: 2012-06-27
Hi ,

I have Hp laptop. Webcam is working some time after that its say hi-speed hub usb prot its something error coming after that it wont working .

if i restart the system it will work ! what is the pblm ??
0
Comment
  • 9
  • 7
  • 4
  • +2
25 Comments
 

Expert Comment

by:MichaelGlancy
ID: 35120458
did you restart to try and find if it would work ?

Also, please explain clearly the error.
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35120467
This USB device can perform faster if you connect it to a Hi-Speed USB 2.0 port
0
 
LVL 3

Accepted Solution

by:
uanmi earned 167 total points
ID: 35120769
This means it is connected to a USB v 1 or 1.1 port or it is seeing the port wrong.
Steps you can try - read all and see what is best for you.

1. Uninstall the wecam from the Administrative tools ->devices. Rebbot and let the machine reinstall  the webcam.
2. Go to windows update and check for updates
3. Ddi you install another USB device before this happened? If so uninstall that device from Administrative tools->devices and then reboot without that device connected.

regards, mark
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35121061
hi mark its inbulid cam
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35121067
more over admin tool dont have devices!!
0
 
LVL 3

Expert Comment

by:uanmi
ID: 35121123
goto the control panel and select administrative tools. There should be a tool called computer management. In this you will find devices which lists all the devices. If there are any not installed correctly they will have a triangle and exclamation mark.

As long as you have the drivers you can uninstall any device and then reboot the computer and the computer will attempt to re-install the device. The computer looks for device drivers on windows update if you have a network connection and will also ask you for the driver disk if you have it.

Something must have caused this to happen? Did the webcam work before?

regards,
Mark
0
 
LVL 41

Assisted Solution

by:Jackie Man
Jackie Man earned 333 total points
ID: 35121914
even if the webcam is inbuilt, the webcam is connected by usb directly the the motherboard.

it can be hardware or software problem.

if it is software problem, try system restore first.

You need to download a Vista Recovery Disk or use your Vista Setup Disk to start your PC and launch system restore to go back to a restore point when there was no problem.

URL: http://www.vistax64.com/general-discussion/146356-download-vista-recovery-console.html

If still no go, as usual, run a sfc /scannow in elevated coimmand prompt first and if still no go, scan for malware afterwards.

Details are as follows:-

Run the Vista System File Checker Tool:

http://www.tech-recipes.com/rx/2231/vista_run_system_file_checker/

1. Open a Command Window in Administrator mode:

* clickStart
* click All Programs, thenAccessories
* right click on the Command Prompt option,
* on the drop down menu which appears, click on the Run as Administratoroption.

* If you haven’t disabled User Account Control (and you shouldn’t!) you will be asked for authorisation. Click the Continue button if you are the administrator or insert the administrator password.

2. Start the System File Checker

* In the Command Prompt window, type:sfc /scannow,
* press Enter.
* You’ll see “the system scan will begin”.

The scan may take some time and windows will repair/replace any corrupt or missing files. You will be asked to insert your Vista DVD if it’s needed.

Close the Command Prompt Window when the job is finished.

One caveat: you need a Windows DVD to enable SFC to make more than minor repairs.

http://support.microsoft.com/default.aspx/kb/928228

“How to analyze the log file entries that the Microsoft Windows Resource Checker (SFC.exe) program generates in Windows Vista”

If sfc /scannow does not work, try to scan for Malware/spyware:

http://www.malwarebytes.org/mbam.php
 
Malwarebytes is as the name says, a Malware Remover!

Download the Free Version from the link above.

Download, install, update and scan once a fortnight..

How to use Malwarebytes after it is installed and Updated:

1. Open Malwarebytes > Click on the Update Tab  across the top> get the latest updates.

2. On the Scanner tab, make sure thePerform full scan option is selected and then click on theScan button to start scanning your computer

3. MBAM will now start scanning your computer for malware. This process can take quite a while.

4. When the scan is finished a message box will appear

5. You should click on the OK button to close the message box and continue with the Malwareremoval process.

6. You will now be back at the main Scanner screen. At this point you should click on theShow Results button.

7. A screen displaying all the malware that the program found will be shown

8. You should now click on the Remove Selected button to remove all the listed malware. MBAM will now delete all of the files and registry keys and add them to the programs quarantine. When removing the files, MBAM may require a reboot in order to remove some of them. If it displays a message stating that it needs to reboot, please allow it to do so. Once your computer has rebooted, and you are logged in, please continue with the rest of the steps.

9. When MBAM has finished removing the malware, it will open the scan log and display it in Notepad. Review the log as desired, and then close the Notepad window.

10. You can now exit the MBAM program.

Source: http://social.answers.microsoft.com/Forums/en-US/vistahardware/thread/c03dab96-f1df-477a-9451-9d665c36fe23

0
 
LVL 12

Expert Comment

by:asidu
ID: 35124800
If the webcam was working before and you hare having the problem now. Its likely to be issue with the driver for the webcam.

You could do a restore to an earlier time when the machine was working fine.

If that does not help. Get to the device manager and totally remove the webcam from the imaging devices.

Next reboot the machine and let the system detect the webcam and reinstall the device again.
All drivers etc will be reloaded.
Test the webcam.


0
 
LVL 3

Expert Comment

by:uanmi
ID: 35124852
Hi Asidu, thank you for restating what I wrote earlier.
regards, Mark
0
 
LVL 12

Expert Comment

by:asidu
ID: 35124876
Sorry mark i over looked your post.
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35140724
Thanks for reply ...

@uanmi: & @ asidu:

As you said its show like triangle . so i uninstall the driver and restarted the pc its working fine for 5 min after that its say the same problem !  :(

@jackieman:
Why i want to check malewares and all ?
0
 
LVL 41

Expert Comment

by:Jackie Man
ID: 35140982
Anyway, run a sfc /scannow in elevated coimmand prompt first to see whether the problem is fixed.

Checking malware is a routine task to exclude the problem is caused by malware.

OR, Try the following.

According to the comment of Tumbleweed36, it says:-

"Delete and install those devices like suggested and if you don't understand how to do that, here are instructions:

You can do this by this method:

        * Unplug all USB items

        * Start

        * Control Panel

        * System

        * Hardware

        * Device Manager

        * View

        * Show Hidden Devices

        * Scroll down to the USB area and open it with (+)

        * Right click on each item and Uninstall all that you have with that option

        * Reboot and let the computer find the USB items.
        * Shut down and Plug items back in and test it by booting up.

When you boot back up, the computer will find them all without difficulty.

Source: http://www.techsupportforum.com/forums/f10/solved-usb-2-0-ports-are-reading-at-usb-1-1-speed-please-help-383230-2.html
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 12

Expert Comment

by:asidu
ID: 35144290
>>so i uninstall the driver and restarted the pc its working fine for 5 min after that its say the same problem ! >>

Drivers installed okie for 5 minutes.
Then some issue of drivers forced to change!
What programs are you running ?

Are you logging in as an administrator.
Try restarting PC log in as Guest to test.
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35144403
>>>>> What programs are you running ?

Hp remmonded sofware youcam !!

>>Are you logging in as an administrator.
Try restarting PC log in as Guest to test.

I tied for all kind of user but no use !!
0
 
LVL 3

Expert Comment

by:uanmi
ID: 35146649
What anti-virus are you running on the PC?

This may sound like an unusual question, but it may give some idea of what is happening.

I agree that you should try another account on the PC that has admin access. You could make another account and put it into the admin group and then login with that account, uninstall the camera and reboot, let the OS find it and install the drivers. I recommend you try to delete the drivers when the device is uninstalled and then let the computer download the drivers fresh from windows update.

regards, mark
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35149942
>>>>What anti-virus are you running on the PC?
avg internet security 2011
0
 
LVL 41

Expert Comment

by:Jackie Man
ID: 35150006
Try to uninstall avg; remove web cam driver; restart pc and check whether the web cam will get malfunctional automatically afterwards.
0
 
LVL 3

Expert Comment

by:uanmi
ID: 35152510
if you uninstall avg, look at installing microsoft security essentials when you rebuild the PC.
Please let me know what happens when you uninstall avg and then uninstall camera driver and try again. Remember to try to remove driver from hard disk, so computer will reload driver from windows update.

regards, Mark
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35158691
one change  ..its work for 20 min ....

i s'down pc after some time started its work for 5 min again...
0
 
LVL 3

Expert Comment

by:uanmi
ID: 35161414
Hi, at some point it may be necessary to re-install the OS. If you have deleted the existing drivers from the hard disk and let the computer re-install the drivers from windows update and if this fails then you may be at a point where there is something else causing the issue, possibly a corruption of the registry or another device that has not installed correctly and is causing this issue.

If you can, and have a restore disk, try to do a restore to a point in time, before the problem occurred.

Sometimes, a re-install of the OS can be a fast way to fix the problem.
0
 
LVL 12

Expert Comment

by:asidu
ID: 35165637
Agree with Mark a re-install is the option which may possibly solve the problem.

Another way you could do, install a spare hard disk if you have one. Install the OS and test. If the new install works fine it would clearly mean that the existing OS on the current hard disk is having some issues.
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35321583
any other option ?
0
 
LVL 41

Assisted Solution

by:Jackie Man
Jackie Man earned 333 total points
ID: 35321699
AVG Internet security 2011 is famous for creating problems.

Have you tried to completely remove it?

http://www.avg.com/us-en/download-tools
0
 
LVL 3

Expert Comment

by:uanmi
ID: 35322245
I recommend you consider the re-install if you cannot uninstall AVG completely. When you do work through the issue, look at the new Microsoft Security Essentials. I'm not advocating a Microsoft solution, but it is free and integrates easily. There are other free options, but sometimes, they can be difficult to turn off or remove.

regards, Mark
0
 
LVL 20

Author Comment

by:Sathish David Kumar N
ID: 35379214
I re install the os it working fine now !!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

SCOPE I WILL CONCENTRATE ON LCD SCREEN INVERTOR , CCFL BULB PROBLEMS.   The old question "My laptop screen is black what can it be ?". POSSIBLE PROBLEMS ARE.  1. INVERTER BOARD IS BAD.  2. CCFL BULB IN LCD SCREEN IS BAD.  3. NO VIDEO TO T…
For some time some of our users experienced package loss on a couple of our Lenovo Thinkpad S531 machines running Windows 8 or Windows 8.1 64-bit OS. I was not able to find many answers online, but did after some investigation I began to suspect Blu…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now