Solved

Setting up Outbound email in Exchange 2007

Posted on 2011-03-13
42
431 Views
Last Modified: 2012-05-11
I am having trouble setting up the smtp transport hub.  This is my first time setting it up.  I can receive emails but cann send.  I've followed drirections online from several forums and know i am doing something wrong.  I have tried both the outgoing mail server name as well as the IP address of the outgoing serer.  

Would someone please give me a step by step to configure the smtp?

Thanks for your  help.
0
Comment
Question by:rexxnet
  • 23
  • 19
42 Comments
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122418
How is your send connector configured?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122422
0
 

Author Comment

by:rexxnet
ID: 35122495
It's probably something dumb i'm doing.  Please see attached. Added automatically Added with some help from a knowledgebase article from MS
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122529
Under the general tab, what is the FQDN?
Do you get an NDR when you try to send?
0
 

Author Comment

by:rexxnet
ID: 35122578
There was nothing there.  I put the name of my outgoing mail server for my ISP.  Should that be correct?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122602
It should something that resolves on the internet like, mail.domain.com.

Here is a previous question with more detail: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22538643.html?sfQueryTermInfo=1+10+30+connector+send+setup

It states:
change the FQDN on the send connector to something that resolves on the internet.

After making the change you will need to restart the  Microsoft Exchange Transport Service.
0
 

Author Comment

by:rexxnet
ID: 35122612
I don't understand.  "Resolves on the Internet"  Does that mean I could use mail.mydomain.com?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122636
Yes if mail.mydomain.com is a valid entry.
If I or anyone outside of your LAN pings mail.mydomain.com will it resolve to a host?
You can put it in, restart the service and see if it works.
0
 

Author Comment

by:rexxnet
ID: 35122641
if i go under a command prompt and type in ping smtp-server.carolina.rr.com, I get an IP address for it.  Is that what you mean?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122661
Yes, I can ping that also.
I always use the one associated with the domain that is sending mail, mail.mydomain.com, but it may not make a difference.
0
 

Author Comment

by:rexxnet
ID: 35122677
but wouldn't i have to go on to my domain registrar and create DNS record for mail.mydomain.com?  Or an MX record?  I know enough to be dangerous.
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122705
Yes you are correct that A record would need to exist for that to work. Many registrars setup many of these A Records by default.

can you ping mail.mydomain.com now?

0
 

Author Comment

by:rexxnet
ID: 35122741
no

Shall I create an A record and try again?  I already have vpn.mydomain.com and remote.mydomain.com pointing to my public address.
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122754
For now you should be able to use either of the ones that exist, vpn.mydomain.com or remote.mydomain.com.

change the FQDN on the send connector to vpn.mydomain.com or remote.mydomain.com.

After making the change you will need to restart the  Microsoft Exchange Transport Service.
0
 

Author Comment

by:rexxnet
ID: 35122771
but what I don't understand is why the known good outgoing mail server that is used for pop mail that doesn't require any type of authentication does not work.  I've even tried to use the IP address of that outgoing mail server.
0
 

Author Comment

by:rexxnet
ID: 35122792
Should the "Points to" address be my public address or the address of the outgoing mail server of my ISP?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122811
Where are seeing the "points to" setting?
0
 

Author Comment

by:rexxnet
ID: 35122821
i log into my godaddy account, click on my domain and manage.  Then where the A records are, I do a quick Add.  It asks for a name, so I call it mydomainemail and the next entry is Points To.  That's the only two things that need to be filled out.  Like if I type either remote.mydomain.com or vpn.mydomain.com, it brings me to my rww.  That's why i'm not sure why I would need anything but remote.mydomain.com.  It's all pointing to the same public address.
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122835
Mail.mydomain.com should point to your public IP just like remote.mydomain.com or vpn.mydomain.com.
But the outgoing connector does not care which one you use as long as it resolves so using either of the two existing should work as well as a new one that is mail.mydomain.com.
0
 

Author Comment

by:rexxnet
ID: 35122847
well..those are in there, the service is stopped and restarted and still cannot send email.
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122874
Might be best to start from scratch with a new send connector.
Disable the current send connector by right clicking it.
Right click the white space choose new send connector
Choose internet
address space of *

If there are other questions that we have not covered post them and I will walk you through it.
0
Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

 

Author Comment

by:rexxnet
ID: 35122928
OK...did that.  Under the general tab should I put the remote.mydomain.com?
0
 

Author Comment

by:rexxnet
ID: 35122939
and you're talking about the mail exchange transport service, correct?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122950
From Exchange Managment Console
Organization configuration
Hub transport
send connectors
0
 

Author Comment

by:rexxnet
ID: 35122972
done that
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35122986
restart the Microsoft Exchange Transport Service ?
0
 

Author Comment

by:rexxnet
ID: 35123019
Yes
0
 

Author Comment

by:rexxnet
ID: 35123030
and FQDN should be remote.mydomain.com on the general tab and address space should be * instead of the smtp-server.carolina.rr.com?
0
 

Author Comment

by:rexxnet
ID: 35123033
i guess I don't understand because my public IP is not an outgoing email server.  
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35123134
When you state "my public IP is not an outgoing email server" are you saying that this exchange server is not intended to deliver email for its' clients?


the address space eventually should be made more exact. We are using * just to eliminate a point of failure during this setup.

the eventual setting would be something like: *.mydomain.com, it asks from were is this mail originating rather than where is this mail going.

from MS: http://technet.microsoft.com/en-us/library/aa998662.aspx

During routing resolution, a Send connector, to which e-mail is routed for delivery to the destination address space, is selected. The Send connector whose address space most closely matches the recipient's e-mail address is selected. For example, an e-mail message addressed to Recipient@marketing.contoso.com would be routed through the connector that's configured to use the *.Contoso.com address space. When you configure a Send connector for a particular address space, e-mail sent to that address space is always routed through that connector. Also, the configuration settings for that connector are always applied to e-mail sent to that address space.

0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35123205
Are you intending to route all outgoing mail through your ISP? That would be a smart host which is a little different that what we have been doing.
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35123587
Is the SMTP service running?

Have you tried the test for in and out SMTP at https://www.testexchangeconnectivity.com/

Have you tried the test for port 25 at http://www.canyouseeme.org, and it verifies that the port is accessible?
0
 

Author Comment

by:rexxnet
ID: 35124643
I'm sorry it's taken me so long to get back to this post.  

Yes.  I plan to send all email through my ISP.  The testexchangeconnectivity.com failed.  Then, I'll send an email to another address I have with Yahoo.  It takes about 10 minutes to get there, but eventually it comes through.  That is with the remote.mydomain.com as the FQDN.  Please see attached.
smtp-test.jpg
0
 

Author Comment

by:rexxnet
ID: 35124653
Both port 80 and 25 are able to be seen.
0
 

Author Comment

by:rexxnet
ID: 35124726
OK.  I sent one message to my yahoo using the .carolina.rr.com address in the FQDN and it went faster.  I sent it to my yahoo and another mydomain.net address.  The one to yahoo is here, the one to mydomain.net is not.  Very strange.  Typically, when I send an email to it from any other source, i get it immediately.  Something still must be wrong.  I even get a failure and retry message from exchange on the yahoo account even though it delivered successfully.
0
 
LVL 13

Accepted Solution

by:
AustinComputerLabs earned 500 total points
ID: 35124735
Since you are you intending to route all outgoing mail through your ISP, we need to setup a smart host.

Disable any send connectors you have and create a new one except this time when you get to the smart hosts entry enter the information for your smart host.
0
 

Author Comment

by:rexxnet
ID: 35124829
Genius. Thank you!
0
 

Author Comment

by:rexxnet
ID: 35124831
mail sent and received immediately with smart host.  any disadvantage in doing it this way?  
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35124874
I am so glad we resolved it.

Next time I will know a few more questions I need to ask before I dive in.

Thanks for sticking with it.

Not really.
Many servers use a smart host.
0
 

Author Comment

by:rexxnet
ID: 35124883
No.  Thank you for sticking with me while learning.  
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35124885
Make sure to test internal mail again.
You may need to set up a send connector for that now that the rest is using the smart host.
0
 

Author Closing Comment

by:rexxnet
ID: 35124890
Expert was very patient while I was learning.  Questions were answered that I didn't even know how to ask.  Thanks again!
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now