my docs redirection slow to open first time in xp

We have set a users My Documents folder to point to a network drive using the drive letter. When the user accesses the My Documents folder for the first in a session it takes a long time come up, but after that first time opens instantly. What is causing this?

We have turned off the windows firewall on the share loaction and the client pc but this has had no effect. Have also tried saving the credentials manually in stored passwords but again no effect.

Any help appreciated.
scottlanoAsked:
Who is Participating?
 
scottlanoConnect With a Mentor Author Commented:
re-redirecting has been tried a few times without success. Browser Master settings as per other clients. Suspect the networking hardware, a combo of a cheap d-link modem/router and a generic Gb switch. Will advise client to upgrade to a reputable Gb switch with enough space to accommodate the server, all clients and the modem (so the modem doesn't have to double as a switch).
0
 
Gary CaseRetiredCommented:
Most likely it's simply browsing the network to locate the share -- then, once it's established the network link, future references are immediate.

... it may be quicker if you use the fully qualified network address rather than a mapped drive -- although I don't recall if XP will allow that for a system folder redirect.
0
 
scottlanoAuthor Commented:
Thanks Gary,

This issue was initially site wide (4 clients and a server) and was resolved by changing the redirection to the drive letter as opposed to the share and also turning the windows firewall off (useless anyway when there is one on the router).

Since then all clients except for one are connecting fine. It is a Gb network, small site, and not much data on the share. Something is wrong with this particular client, there simply has to be if the others are working fine.
0
 
Gary CaseRetiredCommented:
Try redirecting My Docs locally;  then unmapping the drive;  then re-mapping it using a different letter;  and finally redirecting My Docs to the new mapped drive.

If that doesn't do the trick, check your BrowseMaster settings in XP's network configuration.  (since you have several others that work perfectly, be sure they're the same)
0
 
scottlanoAuthor Commented:
Only a recommendation, not tested as a complete solution. It is based on past experience with dodgy d-link hardware and networks where the modem is used as an additional switch because there aren't enough ports.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.