Solved

Exchange 2010 on VSphere 4.0 Consuming Memory and CPU; Memory Leak?

Posted on 2011-03-13
4
710 Views
Last Modified: 2012-05-11
Environment: 2 VMWare VSphere 4 ESXi Hosts each have 2x 6-core CPUs and 48GB RAM
VMW hosts connected through 4GB fiber to FC Disk on EMX CSX3 Clariion.
Problematic Guest: Exch 2010 on Windows 2K8R2 VMDK lives in storage group A (104/134GB consumed)
Exchange vitrual disk lives in storage group B (250GB/270GB consumed)

On Saturday we began migrating mailboxes from Exchange 2003 on a physical machine to a virtual Exchange 2010 on VSphere 4. Just before the migration, we expanded the amount of RAM on the virtual Exchange 2010 server from 4GB RAM to 12GB of RAM.

Started the migration and the CPU pegged and memory was consumed. VMotioned all other VMs off the guest hosting the Exch2010 and increased RAM to 20GB and CPUs to 4. Still the Exch server became unresponsive.

Colleagues are pointing at disk IO not being able to handle the load.

My backup Exchange server which is hosted on identical storage and ESX environment runs smoothly with 4GB Ram.

Any ideas on what is causing my prod Exch server to crawl at snails pace? I noticed that by adding more RAM on the prod environment, the VMSW file has aldo grown to 20GB, but the Exch server is the only guest on a host with 48GB Ram.


0
Comment
Question by:keno44
  • 2
4 Comments
 
LVL 22

Expert Comment

by:chakko
ID: 35125475

Do you mean that the Desktop interface (explorer.exe) on the Exchange 2010 server is unresponsive, or is it the whole server?  

Exchange will use as much RAM as it can and I have seen some servers become 'sluggish' from the console side (desktop or remote desktop), but the services underneath all worked OK

Are you using the Move Mailbox command/feature that is built-in to Exchange?  If yes, then I wouldn't think Disk IO should be a problem.

I adjusted the RAM usage by Exchange and this dramatically improved the responsiveness of the server desktop.  This works for Exchange 2010.

http://mostlyexchange.blogspot.com/2007/08/restricting-ram-usage-in-exchange-2007.html

To restrict the amount of RAM that Exchange is using, you need to use ADSIEdit (from the Windows 2003 Support Tools) and you need to logon as someone that has permissions to edit the Exchange configuration. Navigate down through the Configuration container as follows, the organization name is Somorita and the server name is HNLEX04:
Configuration -> Services -> Microsoft Exchange -> Somorita -> Administrative Groups -> Exchange Administrative Group (FYDIBHOHF23SPDLT) -> Servers -> HNLEX01 -> Information Store.

Right click on CN=Information Store and choose Properties; locate the msExchESEParamCacheSizeMax property.


Actually, there is a calculation here. If you want to restrict the size to 10GB. Convert that into KBs(10GB = 10485760 KB) and devide that by 8(10485760/8 = 1310720) and keep that value in msExchESEParamCacheSizeMax.

1024 * 1024 * 10 (GB) / 8 (bits) = setting to use

Reference : http://technet.microsoft.com/en-us/library/bb691304.aspx

0
 
LVL 16

Accepted Solution

by:
danm66 earned 500 total points
ID: 35125481
edit settings on the VM's and check the resource tab.  Make sure you don't see that the box for 'unlimited' un-checked for processor and, especially, memory.

If you look at the performance tab for the VM's, check the latency on the storage, too.  If you see that latency is above 25ms for more than a brief peak, then you might have some storage concerns depending on how long and how high the latencies go.
0
 
LVL 3

Author Closing Comment

by:keno44
ID: 36977215
Sorry, this happened a while ago. I modified setting the memory setting, hard coded it to not go above the desired amount of memory and this turned out to be the solution for our issue.
0
 
LVL 16

Expert Comment

by:danm66
ID: 36977740
I just leave it at unlimited because VM can't use more memory than what it's configured with at boot time.  So, if you assign it 4GB, the most it can use is 4GB plus a small amount for overhead.  The problem with hard setting the resource limit is that you might increase the RAM at some point in the future and not remember to lift the ceiling and windows doesn't like it when you tell it that there's a certain amount of memory available and it can't go out and touch all of it to create pointers.  That's what causes the slowness of performance.
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2013 DL hack 4 32
VAAI  technology 2 57
export the mailbox data to .pst from office365 mailbox 8 50
Purchase larger hard drive for Dell Latitude e7250 laptop 3 67
When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
Is your phone running out of space to hold pictures?  This article will show you quick tips on how to solve this problem.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question