Windows 7 taking forever to logon to domain

Hello, I recently upgraded to a new network router and switch, and since then my computers have been taking at least 5 minutes to Log On to the domain after entering the password. It sits there and says "Please Wait..." and is very annoying. Any suggestions? The computers are on a Win 2003 domain. Thanks!
ls2gtoAsked:
Who is Participating?
 
Lee W, MVPConnect With a Mentor Technology and Business Process AdvisorCommented:
What you have right now is incorrect and likely the cause of your problems.  Change the DNS Server setting on the TCIP/IP properties of the Network card so that it is 192.168.1.5.  Then set all workstations to ALSO use 192.168.1.5 ONLY

(Frankly, it's not advised to use 192.168.1.x as that can create problems if you try connecting with VPN.  You should be using a number other than 1 or 0 - I typically pick an easy number like part of the address - if my business were at 42 Main Street, then I'd use 192.168.42.x - so long as that third number is greater than 9 and less than 255.  (Otherwise, use the first two digits of your phone number or something)).

0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Check your DNS Settings - especially if you forgot to disable DHCP on the new router.
0
 
Sajid Shaik MSr. System AdminCommented:
check the proper network settings and re join the domain it may be help ful... ene not re create user and rejoin the domain...

all the best
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Misconfigured DNS often results in login delays.  DNS should point ONLY to the Domain Controller's DNS server.  DHCP, if it was switched to your router (especially if it was accidental) would not contain the correct DNS servers)
0
 
ls2gtoAuthor Commented:
I forgot to mention that all network settings are thru the router. Nothing on the server is configured for DHCP or DNS.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Then that's probably your issue.  Your ISP has NO IDEA where to find the authenticating server, but your clients are asking your ISP where to go.  Proper DNS configuration is ESSENTIAL to a working environment.  

Your Server should point ONLY to itself for DNS; your workstations should point ONLY to the server for DNS - no "additional" DNS servers from your ISP (yes, if your server is down, you can't browse the internet - but if your server is down, you have bigger problems).
0
 
ls2gtoAuthor Commented:
Thanks, but I am a bit confused. I have attached a screenshot of my server's ethernet card network settings if that helps. Currently, I have all of the workstation computer's ethernet adapter DNS settings pointed to the server's IP address of 192.168.1.5, along with a manually assigned IP address that I just setup (it was automatic before).  Am I doing something wrong?  I wasn't sure if I should change the DNS Server settings on the server to 192.168.1.5 as well since that is the IP of the server?



 network settings on server
0
 
ls2gtoAuthor Commented:
That did not work, any other suggestions?
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Post a screen shot with your current settings from BOTH the server and the workstation.
0
 
ls2gtoAuthor Commented:
Actually, that did it. I forgot to restart Win2003, and its now all good. Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.