Solved

QuickReport

Posted on 2011-03-14
6
2,200 Views
Last Modified: 2012-05-11
I had version QR407PD6 for delphi
and then i Instaled version QR502PD6.

Now, when I change report on sreen occur report.page.continuous: Property Continuous does not exist.

I use Delphi 6

Thx
0
Comment
Question by:hrvica5
6 Comments
 
LVL 15

Expert Comment

by:mikelittlewood
Comment Utility
Might just find you need to cut and paste the report component back on to fill in any missing properties.
Sounds like they added or removed that property depending what is saved on your form.

Have you tried turning the form to text and looking for the property?
0
 
LVL 19

Accepted Solution

by:
Thommy earned 500 total points
Comment Utility
property CONTINUOUS is new in QR5.

Seems that your Delphi project still tries to access old QR4 component file(s).

Make sure that QR4 and its files are completely removed before installing QR5:

1.) Open COMPONENT/INSTALL PACKAGES... and remove all QuickReport Components

2.) Delete dclqrt60.bpl and dclqrt60.dpk

3.) Install QR5




D6-Component-Install-Packages.jpg
0
 

Author Comment

by:hrvica5
Comment Utility
I unninstalled every qr and then i installed QR5.0.2. , but now when i'm trying to start application, it occur
File not found: 'QR4Const.dcu
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 19

Expert Comment

by:Thommy
Comment Utility
QR4Const is from the old QR version.

It is still in one of your project's USES lists.

Search for QR4Const and replace it with QR5Const.

Can you please provide your project file (.DPR) and your unit, which contains the report components (.PAS and .DFM)
0
 
LVL 22

Expert Comment

by:Ferruccio Accalai
Comment Utility
I got a similar problem because I had some TeeChart components (TQRChart and TQRDBChart) already installed that were compiled using QR4 version.
If so you have to uninstall those components or at least recompile the TeeChart package (but you need the source code)
0
 

Author Closing Comment

by:hrvica5
Comment Utility
Partially solution
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

In this tutorial I will show you how to use the Windows Speech API in Delphi. I will only cover basic functions such as text to speech and controlling the speed of the speech. SAPI Installation First you need to install the SAPI type library, th…
In my programming career I have only very rarely run into situations where operator overloading would be of any use in my work.  Normally those situations involved math with either overly large numbers (hundreds of thousands of digits or accuracy re…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now