Solved

Two exchanges in seperate domains configure mail flow

Posted on 2011-03-14
63
1,034 Views
Last Modified: 2012-05-11
I have an exchange2007 in abc.com domain,
I have an exchange2010 in yxz.com domain

How to configure exchange2007 to route all the mails to exchange2010 as only exchange 2010 is poiting to public IP.
0
Comment
Question by:-MAS
  • 36
  • 27
63 Comments
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 500 total points
ID: 35127566
on exchange 2007 -> EMC -> org config -> Hub transport-> send connector edit your current send connector and make it use the IP of 2010 as smart host relay

on exchange 2001 -> emc -> server config -> hub tranposrt -> create a new receive connector make it accept connections from the IP of 2007 and allow relaying on it

0
 
LVL 24

Author Comment

by:-MAS
ID: 35127657
Exchange2010.nsportq8.local #530 5.7.1 Client was not authenticated ##

I am getting this error

What could be wrong
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35127668
did you do what I told you in the second step ?

" allow relaying on it"

0
 
LVL 49

Accepted Solution

by:
Akhater earned 500 total points
ID: 35127675
0
 
LVL 24

Author Comment

by:-MAS
ID: 35127724
I did as per the article but still the same error.

Below is the result I got after I ran the command

Identity             User                 Deny  Inherited
--------             ----                 ----  ---------
EXCHANGE2010\2007... NT AUTHORITY\ANON... False False
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35127737
restart the msexchangetransport and try again
0
 
LVL 24

Author Comment

by:-MAS
ID: 35127805
I restarted both transport services

But still the same.

0
 
LVL 49

Expert Comment

by:Akhater
ID: 35127833
when r u getting this error ?

on your 2k10 issue a get-receiveconnector | fl  and give me the results
0
 
LVL 24

Author Comment

by:-MAS
ID: 35127870
Attached th result from exch2010
Results.docx
0
 
LVL 24

Author Comment

by:-MAS
ID: 35127880
I am getting this error when I send email from exchange mailbox
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35127951
I take it the name is : 2007-2010 right ?

what is RemoteIPRanges : {10.0.0.188-255.0.0.0}
0
 
LVL 24

Author Comment

by:-MAS
ID: 35127984
yes name of the receive connector is '2007-2010'

IP of the exch2007 is 10.0.0.188    abc.com domain
IP of the exch2007 is 10.0.0.27      xyz.com. domain
0
 
LVL 24

Author Comment

by:-MAS
ID: 35128009
yes name of the receive connector is '2007-2010'

IP of the exch2007 is 10.0.0.188   in  abc.com domain
IP of the exch2010 is 10.0.0.27    in  xyz.com. domain
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35128013
t should be what 255.255.255.255 not 255.0.0.0

0
 
LVL 24

Author Comment

by:-MAS
ID: 35128085
changed the subnet mask to 255.255.255.255
eventhen  

#530 5.7.1 Client was not authenticated ##

I am sorry to disturb you.

Many thanks for your support
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35128279
on the connector you have created right now in the permission groups tab did you check the anonymous ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35128336
New-ReceiveConnector -Name AllowRelay -usage Custom -Bindings '10.0.0.27:25' -fqdn exch2k7.domain.com -RemoteIPRanges 10.0.0.188 -server exchange2010.domain.com -permissiongroups AnonymousUsers

I am going to create new connector

The above command is correct?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35128342
Please check post #35128009 for server IP addresses
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35128489
New-ReceiveConnector -Name AllowRelay -usage Custom -Bindings '10.0.0.27:25' -fqdn exch2k7.domain.com -RemoteIPRanges 10.0.0.188 -server exchange2010.domain.com -permissiongroups AnonymousUsers

This command is correct if you do this you will need to delay the other one
0
 
LVL 24

Author Comment

by:-MAS
ID: 35128575
other one means exchange2007?
as exchaneg2007 ip is 188

I want to relay mail through exch2010 to internet.

0
 
LVL 49

Expert Comment

by:Akhater
ID: 35128596
no other ones means the connector you have created before "Exchange 2007-2010" you will need to delte it
0
 
LVL 24

Author Comment

by:-MAS
ID: 35128994
Sending is ok

Now how I will receive emails from outside

Mail not receiving from out.

Please help to sort that also
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129002
what about receiving ? how are you expecting to receive ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129044
I have the same accepted domain names created in both the exchange server.

As you are aware that I am moving all the mails from exchange 2010 to 2007
and install exchange2010 again and move back as you said in
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_26879979.html

Please help to receive mails so that I can start exporting and imprting to the new exchange and get rid off
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129089
on your 2010 you have to configure your domain as internal relay and not authoritative

then on 2010 create a send connector with a cost of 1 smart host ip of 2007
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129133
--->on your 2010 you have to configure your domain as internal relay and not authoritative

you mean in exchange2007?

---> then on 2010 create a send connector with a cost of 1 smart host ip of 2007

There is already one send connector with cost 1
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129154
--->on your 2010 you have to configure your domain as internal relay and not authoritative
no i mean on 2010 it is one connected to the internet no ?


---> then on 2010 create a send connector with a cost of 1 smart host ip of 2007
I mean create a send connector with address space yourdomain.com and smart host ip of 2007 this is what you did??
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129206
What is the cost as there is already one send connector with cost 1
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129275
what ? what are you talkign about ?
 you have a send connector FROM 2010 TO 2007 ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129361
I have a send connector before that is sending mails to outside.

Now I have created one more with same cost, address pace  in exchange2010
address :  domain.com
cost : 1

0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129373
this one is correct what OTHER one do you have ?


did you set domain.com as internal relay instead of authoritative ?
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 24

Author Comment

by:-MAS
ID: 35129651
yes I made it internal instead of authoritative

Now mail from exch2007 is reaching ouside and to exch2010 users

where as mail from exch2010 is not going to exchange 2007

it is bouncing back with below error
#530 5.7.1 Client was not authenticated
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129682

how many send connectors do you have on your exchange 2010 ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129692
2 send connectors
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129701
on your exchange 2007 how many receive connectors ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129738
2 receive connectors

Attached the screenshot of both exchange
screen.docx
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129778
Now everything is working except mail from exchange 2010mailbox  to exchange 2007mailbox
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35129787
in your Default Receive connector in exchange 2007 proprties permission group do you have Anonyous checked ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129883
Many thanks for your time spent. It is working now.

But sorry to tell you this. Now outside mails to exchange 2007 is showing below error

Delivery to the following recipient failed permanently:
    abbasiftt@nsportq8.com
Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 5.1.1 User unknown (state 14).
0
 
LVL 24

Author Comment

by:-MAS
ID: 35129971
Anyway we can sort this.
I know this is difficult but only EE experts can help in this case.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35130236
What are you talking about ?

When are you havingthis error ? When who is sending to who and what isthe relation of google in this?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35130271
I created a test email in exchange2007

When I send mail from that account it is going out where when I reply for that mail from gmail is bouncing back.

0
 
LVL 24

Author Comment

by:-MAS
ID: 35130277
Now exchange2007 users not receiving mails from outside.
0
 
LVL 24

Author Comment

by:-MAS
ID: 35136286
Any luck to receive mails in exchange2007
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35136363
what is going on with you in a previous message you told me it is working
0
 
LVL 24

Author Comment

by:-MAS
ID: 35136395
It was working After I configured mail flow from 2010 to 2007 mail from outside org  is not coming to 2007 mailbox.

Now only issue is incoming mails to exchange2007 from internet is not working
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35136407
let's go over this one more time

on exchange 2010 issue a

get-sendconnector | fl

and give me the results
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138168
BTW both the exchange is having same accepted domain names

I think you know that.



0
 
LVL 49

Expert Comment

by:Akhater
ID: 35138398
yes I know that but this accepted domain on 2k10 is set to internal relay not authoritative right ?

did u create a user with the same emaail address on btoh 2k7 and 2k10 ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138463
Yes I tried that also. but it is delivering only to user in exch2010

In exchange 2010 accepted domain is internal relay
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35138494
exactly if the user exists in 2k10 it will be delivered ONLY to 2k10, it will be delivered to 2k7 ONLY if the user does not exist on your 2k10
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138575
result attached
Result.docx
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35138632
ok this is correct

what is happening if you send an email to a user on 2k7 and NOT on 2k10 ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138680
I am getting the error as in  post #35129883
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35138719
the error in the post is "User unknown"

do you have an antispam in front of your exchange server ? exchange edge or anything ?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138772
Exchange forefront server protection
0
 
LVL 24

Author Comment

by:-MAS
ID: 35138822
I have cyberoam antispam also


0
 
LVL 49

Expert Comment

by:Akhater
ID: 35138901
one of them is checking in AD if the user exists or not and this is the one responsible for your problem
0
 
LVL 24

Author Comment

by:-MAS
ID: 35139282
Any workaround you know for this?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35139334
Create users on both exchanges and create rule in each exchange2010 users  to forward mails 2007user

Will it work?
0
 
LVL 24

Author Comment

by:-MAS
ID: 35146306
FROM THE ERROR ATTACHED CAN YOU MAKE OUT  WHAT IS WRONG.

ERROR.txt
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35154682
I already told you the problem if from your anti-spam

what you can do is create the user in 2010 and make it forward to another email address for the same user in 2007 and create a connecter for that domain
0
 
LVL 24

Author Comment

by:-MAS
ID: 35154796
My plan changes I am doing this the otherway.

I will nat the exchange2007 to internet and let exchange2010 relay all the message to 2007.

That is the only solution for this

Can you help by giving a breif idea in a single post
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now