[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 783
  • Last Modified:

Novell 3.12 boot problem

I have a Novel 3.12 system that is getting a "No boot device found" error. Apparently the boot records are corrupt. Is there a way to create a 3.12 boot floppy that will get into to root drive to see what the issue is? WIll a DOS boot floppy do this?
0
Randy_Haley
Asked:
Randy_Haley
  • 5
  • 4
  • 2
  • +1
3 Solutions
 
deroodeCommented:
Any DOS boot floppy will be able to see if the harddisk is still working and accessible. Also check you BIOS to see if the harddisk is visible.
Novell Netware 3.12 is booted from a small DOS partition which starts server.exe from autoexec.ncf. If the Master boot record is defective you can boot from floppy and start Server.exe from C:\ or C:\nwserver.
0
 
Randy_HaleyAuthor Commented:
I have dug deeper and found that the RAID is the problem. I have 4 drives set up as RAID 5. For some odd reason, 3 of my drives failed over the weekend. I find it odd that 3 hard drives would fail at one time. They are showing up in the Disk utilities of the Perc3/di software but when I look at the containers, all my fujitsu drives are missing.

Could this be a RAID controller issue or possibly a backplane issue?

Randy
0
 
PsiCopCommented:
<pet peeve>
There's no such thing as Novell 3.12.

Novell is a company. It makes a number of products, including SUSE Linux, GroupWise, eDirectory and NetWare.

You're running NetWare v3.12.
</pet peeve>
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
PsiCopCommented:
Yes, it does sound like a hardware problem. Trouble is, it really could be the drives that have failed. Telling the difference could be a little tricky.

How about your backups? You do have backups, don't you?
0
 
PsiCopCommented:
I find it odd that 3 hard drives would fail at one time.

Maybe, but maybe not. Were they all installed/put in service at the same time? Are they all about the same age? Same OEM, similar serial numbers?

If they're all of the same vintage, then they may have all reached MTBF (Mean Time Between Failures) at about the same time. In which case the timing of the failures may not be all that extraordinary.

Do they spin up at all?

It's been awhile since I worked with PERC, but I seem to recall the array configuration info was stored on the drives rather than the controller. Do you have a similar machine, with the same model PERC and drive bay arrangement? I'm thinking if you can put the drives, in the same order, in a similarly-equipped system, and the RAID configuration info is on the drives, then you'll be able to determine if the failure is in drives or the controller.
0
 
Randy_HaleyAuthor Commented:
Ok, I get it. Forgive me for not saying Netware....

And yes, I do have backups but it is a tape. It is backed up nightly using Backup Exec for "NETWARE"...

That all being said, I did have another PE2500 server with the same hardware raid controller. I had already tried taking the drives out of the old system and putting them in the backup PE2500. Same issue.

I did resolve the issue but only after installing two SCSI drives the same size as what I had. I ran the RAID controller setup at startup and attempted a ALT-R. Fortunately, it fixed it. I really don't know how it repaired the RAID with two bad drives but it did.

It turned out that it was 2 drives that failed out of 4. The 4 drives were RAID 5 and had two containers. Container 0 consisted of the boot drive and SYS volume. Container 1 consisted of the APP and LFN volume.

After the rebuild, I had to run LOAD C:VREPAIR to fix the SYS volume and it was done.
0
 
PsiCopCommented:
Wow! You are a lucky son-of-a-gun.

Are you sure one of the failed drives wasn't a Hot Spare? That's about the only way I can imagine you getting back a failed RAID 5 array where 2 drives went out.

Congrats on pulling the system back from the brink. Don't forget to get a refund of your points.

Perhaps for your next trick, you'll upgrade to a NetWare version from this century? :-)
0
 
Thomas_RoesCommented:
Sometimes a drive that get's a failed flag in your RAID controller, but isn't all bad. In some raid controllers you can tell the controler the drive is fine, no matter what. Sometimes, RAID controllers do this by them selves. This is how your RAID could have come back. but this is the kind of luck you don't build your company on

I've had a similar situation where I saved the day one's, a second time, a third, everytime telling it was luck and I coudn't promise a next fix. One day luck ran out . . . .

Have a very good backup and plan replacing your hardware very soon

0
 
Randy_HaleyAuthor Commented:
Well, luck ran out. The entire RAID failed and I had to build from scratch. I do have a tape backup of the server but am running into issues loading the drivers for the cd-rom and scsi tape device.

The system is a Dell PE2500 with a PERC 3/Di controller. The backplane is plugged into port 0 of the RAID controller and the tape device is plugged into port 1 of the RAID controller. The CD is plugged directly to the motherboard via a scsi cable.

I can access the hard drives when I: LOAD PERC2.HAM slot=10009

I can't access the CD-ROM or Tape device...and when I try to load NWASPI, it tells me the file is corrupt. Any ideal where I can get Netware 3.12 drivers off the net?
0
 
deroodeCommented:
When you search for nwaspi.cdm it can still be found: Nwaspi.cdm was in the nwpaup1a update:

https://secure-support.novell.com/servlet/filedownload/uns/pub/nwpaup1a.exe/

It is not available anymore on novell.com, but there are a few mirrors that carry this file:

ftp://ftp.uni-leipzig.de/pub/novell/410/nwpaup1a.exe
0
 
Randy_HaleyAuthor Commented:
Ok, I after working on this issue for 3 solid days, I finally had to give it to someone with netware 3.12 experience. They are in the process of restoring my server from tape.

Randy Haley
0
 
Randy_HaleyAuthor Commented:
An answer was never found but I awarded points on effort. Thanks again.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now