• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 737
  • Last Modified:

IIS 7 http redirect to https

Hi,
I recently installed ssl and now all my clients visit my site as https://servername.domainname.com
still some of the clients visit http://servername.domainname.com and get page 403 forbidden.  I want if some one still visit as http should be auto redirected to https.  How and where in IIS 7 can I do this.  Suggest plz
0
amanzoor
Asked:
amanzoor
  • 2
  • 2
2 Solutions
 
MAS (MVE)Technical Department HeadCommented:
Create a new webiste bind with port 80 and redirect it to
 https://servername.domainname.com
0
 
pramodsk40Commented:
Thats a good way as abbasiftt suggested...also specifically for IIS7 these are the ways available which you can use...

http://www.sslshopper.com/iis7-redirect-http-to-https.html
0
 
amanzoorNetwork infrastructure AdminAuthor Commented:
Hi guys:
No luck.  At the moment at my router I have enabled only port 443 do I have to enable port 80 for this redirection to work?
0
 
MAS (MVE)Technical Department HeadCommented:
you try from internal network first.

If that works then configuration is fine.

Is it working within your network?
 
0
 
amanzoorNetwork infrastructure AdminAuthor Commented:
abbasiftt:
I will be in the office tomorrow and will let you know.
THanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now