How do I set Exchange 2007 for a large message

I am trying to configure a Small Business Server to accept messages of up to 25 Mb. Everytime I try to do this I am stumped.

If I perform telnet company.com 25 I see the following
220 remote.company.com Microsoft ESMTP MAIL Service ready at Mon, 14 Mar 2011
 11:04:39 -0600

I then put in ehlo and my own domain
ehlo myowndomain.com
250-remote.company.com Hello [137.xxx.xxx.xxx]
250-SIZE 10485760
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING

I am not sure what the size represents. If this is bytes, KB or Mb.
Also I have some screen shots of Exchange configuration here.


 Server Config Hub Transport Properties
 Mailbox Database Properites

Transport Settings

Recipient Malbox Restrictions
Can you help me determine what I am missing?
LVL 1
LostInWindowsAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
The following is an SBS 2008 specific guide for doing so. Keep in mind the 'rest of the world' may not be able to deal with messages of this size.
http://blogs.technet.com/b/sbs/archive/2008/10/28/how-do-i-change-message-size-limits-in-exchange-2007.aspx
If using the POP connector you will also need this article:
http://blogs.technet.com/b/sbs/archive/2009/07/01/sbs-2008-introducing-the-pop3-connector.aspx
0
 
bwiser1Commented:
Firstly, I am not all that familiar with SBS 2008, but I typically change my message limits through the Exchange Shell. I find that's a quick way to get it set and move on.

Type this at the Shell to display what your current settings are:
Get-Transportconfig –maxreceivesize

I would review those settings and then use the following commandlet:

Set-TransportConfig -MaxReceiveSize 25MB

Microsoft put out a great TechNet article on it here:
http://technet.microsoft.com/en-us/library/aa997706(EXCHG.80).aspx

0
 
bwiser1Commented:
Robwill,

Great suggestions! I apologize I didn't mention that you still have to keep in mind typical recipient settings for outside addresses such as ISP's etc., (A commonly forgotten item)
0
 
Rob WilliamsCommented:
No need to apologize bwiser1. Just another thought. :-)
Cheers!
--Rob
0
 
LostInWindowsAuthor Commented:
Pesky SBS. More than 1 setting for 1 concept. Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.