• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 434
  • Last Modified:

wordpress blog permalink question

So in my wordpress site, I have the permalink set to / so that all  my internal pages look like the following:

http://www.domain.com/internal-page/

However, I can't get to the comments on my blog page. When I click on the comments link in my blog post, it just goes to the home page.  Do I need to adjust something in my .htaccess file?

Also,is it best to place the blog in the root directory or in a separate sub directory?  Also, for seo purposes, which is best?
0
COwebmaster
Asked:
COwebmaster
1 Solution
 
bitlaCommented:
yes its best practice to use blog in root directory, it helps SEO. Placing blog in sub directory will not resolve the issue.

Its unusall problem and i am finding soltuion. I need some time
0
 
bitlaCommented:
Normally All Comments are displayed.
0
 
COwebmasterAuthor Commented:
yes, but for some reason they are not.  I do see a link for 2 Comments next to the blog title but when I click on it, it just goes to the home page.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
bitlaCommented:
here are some default settings

www.yourdomain.com/wp-admin/options-discussion.php

Check box the below items

      
Default article settings Attempt to notify any blogs linked to from the article.
Comment author must fill out name and e-mail
Break comments into pages with top level comments per page and the page displayed by default
A comment is held for moderation
0
 
COwebmasterAuthor Commented:
yes, those are checked with still it goes to the home page.
0
 
jeremyjared74Commented:
Do you have a comments.php, or an archive.php in your theme files?
0
 
COwebmasterAuthor Commented:
no.  in root, I have the following:

wp-comments-post.php
wp-commentsrss2.php

there is no archive file.  those are files in the root, not in the /wp-content/themes/[named theme]/
0
 
EZFragCommented:
Hi there,

What I usually do is set my permalink to "/%category%/%post_name%/" (Not 100% sure of the perma link, but it is down that line. This one may have a typo).

Then I create a home page and a blog page. I then setup wordpress to display the blog when the the created blog page is viewed, and the home page when the created home page is viewed. Hope that make sense, it doesn't to me :P

I find that this setup works best for me concerning the url structure of a wordpress website. The structure I then end up with is:

http://website.com/
http://website.com/blog/
http://website.com/industrial/tractors

The tags and comments should remain the same without any issues. I haven't had any issues yet

Hope it helps ^_^
0
 
gwkgCommented:
You must use one of the structure tags.

/%postname%

will give you the same result
0
 
COwebmasterAuthor Commented:
That worked.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now