Turn off Macro and Use VBA

I have always been able to force Access to use VBA instead of macro's by marking Use Event in Access Options. For some reason, in a new Access 2007 database I wrote, it does not work and still gives me Macros. I have closed and opened the data base, started new form, still get Macros

Thanks

Mike
MistebarAsked:
Who is Participating?
 
Jeffrey CoachmanMIS LiasonCommented:
To clarify what Jim posted...

In an Access 2007 or newer *Format* database, the wizards will only create Macros.

If you want the wizards to create VBA code, then you will have to convert the DB back to the 2002-2003 format.

However, this one benefit is, IMHO, not worth converting the format for.

Like most Experts here, I have pretty much memorized any wizard code, and can write it myself.
Remember the wizards only do fairly basic things anyway, ...so it is not that hard to use the wizards at first, then simply copy the code they create to a note pad file to use for reference.
;-)

(Also remember that Intellesense and the VBA help files are always there to help.)

;-)

JeffCoachman

0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Do you have the property set to Yes shown in the image ?

mx
Capture1.gif
0
 
Boyd (HiTechCoach) Trimmell, Microsoft Access MVPCommented:
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
Mike,

  Starting with A2007 and Microsoft's new focus on macros, there is no longer an option to have it create VBA instead of a macro.

  Setting the option MX mentioned above now only affects the use of the builder button (...).

  There is a macro to VBA converter button on the ribbon.

JimD.
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
"there is no longer an option to have it create VBA instead of a macro."
Where or what is this ?

I'm not being forced to create Macros in any of my A2010 dbs ...

mx
0
 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
<<I'm not being forced to create Macros in any of my A2010 dbs ...>>

  Wizards will not generate anything but macro's...

JimD.
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
oh.  Well, in never having used the wizards ... guess I would not notice that.

mx
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
<Has anyone notice the the Expert Ranking (genius, guru, bozo, etc) is missing under the EE emoticons ?
Not sure when this started, but I just posted this on the Bug page>

mx
0
 
Jeffrey CoachmanMIS LiasonCommented:
Hey, I never got my Bozo shirt...
;-)
lol
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Yeah ... they were special order only !
0
 
MistebarAuthor Commented:
A very thorough answer.

Thanks

Mike
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.