• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1547
  • Last Modified:

Virtual desktop - RDWEB

I am having a problem that i'm not sure how to fix. I have the virtual desktop infrastructure setup in Server 2008 r2. It all works good on domain.local. However; if I try and access the resources outside of domain.local (we'll say external.com), I get the "remote computer was not the one you specified" error.

Any way to append the domain.local to the connections? I'm assuming it is failing because the connection broker is giving out just the computer name instead of computername.domain.local
0
ded2545
Asked:
ded2545
  • 5
1 Solution
 
ded2545Author Commented:
Also, one more thing to add - when I try and utilize a "pooled" machine through RDWeb, I get "An error occurred while remote desktop connection was starting the virtual machine .."

Both machines in the pool are started and are able to be remoted into directly. It sits at the screen saying "waking up virtual machine".
0
 
kevinhsiehCommented:
I assume that it isn't working because you don't have the Remote Desktop Gateway configured. Internally RDweb tells you which server to connect to via 3389, but that isn't open from the Internet. The RD Gateway can proxy that connection between the external client and the internal servers. It takes in https from the clients and send that to the servers over 3389.
0
 
ded2545Author Commented:
I thought about that too however; all of this is taking place inside my firewall. I have two independent domains (probably should have specified that .. sorry). I'm almost positive it's something with how the GD Gateway is passing the connection ... i think it's saying "go to computer123" .. instead of "computer123.domain.local".  I have no idea what setting is jacked that is causing this. It used to work after I set it up but after a reboot, it stopped.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
ded2545Author Commented:
Ok, I figured out one part of my problem. Somehow, the permissions for "TS Computers" was removed from WMI. I re-added and the remote apps now show up. However; I'm still having issues with the redirector. I checked in the logs and i'm getting the following 3 entries ...

RD Connection Broker received connection request for user DOMAIN\j_doe.
Hints in the RDP file (TSV URL) = tsv://VMResource.2
Initial Application =  
Call came from Redirector Server = server1.domain.local
Redirector is configured as Virtual machine redirector


RD Connection Broker has successfully determined the end point for this connection request.
Endpoint name = vt-05.domain.local
Endpoint type = Non Farm
Resource plugin name = VMResource


RD Connection Broker successfully processed the connection request for user DOMAIN\j_doe. Redirection info:
Target Name = vt-05
Target IP Address = 172.30.18.105
Target Netbios = vt-05
Target FQDN = vt-05.domain.local
Disconnected Session Found = 0x0


I don't see anything wrong but i'm not sure.
0
 
ded2545Author Commented:
doesn't seem like there is much help for RDP!
0
 
ded2545Author Commented:
dunno...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now