[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now


Cisco AnyConnect Client Image Error: Invalid File Format - Unable to load SVC Image - Extraction Failed

Posted on 2011-03-14
Medium Priority
Last Modified: 2012-08-13
I'm having trouble uploading AnyConnect Client Images to my ASA 5510. I've never seen this error before and can't find it posted online. I've tried uploading various AnyConnect files with the extension mst, exe, targ.gz, and msi files. I'm downloading them directly from the link shown in the ASDM that points me to the Cisco software download page: Products Security Virtual Private Networks (VPN) Cisco VPN Clients Cisco AnyConnect VPN Client Cisco AnyConnect VPN Client v2.x AnyConnect VPN Client Software

I'm running ASDM 6.3 and ASA 8.3(2)

[OK] webvpn
svc image disk0:/anyconnect-win-2.5.0217-k9.pkg 1 regex "Windows NT"
       Invalid file format
ERROR: Unable to load SVC image - extraction failed

Question by:First Last
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5

Author Comment

by:First Last
ID: 35132556
I know I should be doing this via the CLI. So, I followed the directiions located here and it also fails on step 2.

Here what I typed and the output. Same error as stated previously.

ASA(config)# copy tftp flash

Address or name of remote host []?

Source filename []? anyconnect-dart-win-2.5.2019-k9.pkg

Destination filename [anyconnect-dart-win-2.5.2019-k9.pkg]?

Accessing tftp://!!!!!!!!! (upload output omitted)
Writing file disk0:/anyconnect-dart-win-2.5.2019-k9.pkg...!!!!!!!!!!!!!! (write to disk output omitted)

5278629 bytes copied in 5.590 secs (1055725 bytes/sec)
ASA(config)# webvpn
ASA(config-webvpn)# svc ?

webvpn mode commands/options:
  enable    Enable SSL VPN Client
  image     SSL VPN Client package file path
  profiles  AC profiles package filepath.
ASA(config-webvpn)# svc image anyconnect-dart-win-2.5.2019-k9.pkg ?

webvpn mode commands/options:
  <1-65535>  Order for the SSL VPN Client package
  regex      Specify the regular expression to match this package
ASA(config-webvpn)# svc image anyconnect-dart-win-2.5.2019-k9.pkg 1
ERROR: Invalid file format
ERROR: Unable to load SVC image - extraction failed

Author Comment

by:First Last
ID: 35132666
This is now even making less sense to me.

ASA# sh run webvpn
 enable FIOS
 svc enable
 tunnel-group-list enable

ASA(config-webvpn)# sh webvpn svc
SSL VPN Client is not enabled.
LVL 57

Expert Comment

by:Pete Long
ID: 35132696
do you get the same error with the non DART package?

Release Date: 15/FEB/2011
Web deployment package without DART for Windows platforms.
Size: 4577.05 KB (4686889 bytes)
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.


Author Comment

by:First Last
ID: 35132759
I just tried it as shown below. Same issue unfortunately.

ASA(config-webvpn)# copy tftp flash

Address or name of remote host []?

Source filename [anyconnect-win-2.5.0217-k9.pkg]? anyconnect-win-2.5.2019-k9.$

Destination filename [anyconnect-win-2.5.2019-k9.pkg]?

Accessing tftp://!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!Writing file disk0:/anyconnect-win-2.5.2019-k9.pkg...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!4686889 bytes copied in 5.20 secs (937377 bytes/sec)
ASA(config-webvpn)# svc image ?

webvpn mode commands/options:
  disk0:  SSL VPN Client package file path
  disk1:  SSL VPN Client package file path
  flash:  SSL VPN Client package file path
ASA(config-webvpn)# svc image flash:anyconnect-win-2.5.2019-k9.pkg
ERROR: Invalid file format
ERROR: Unable to load SVC image - extraction failed

Here is my sh flash to sh where it is:

ASA(config-webvpn)# sh flash
--#--  --length--  -----date/time------  path
  118  5548032     Dec 31 2002 19:05:38  asa708-k8.bin
  119  4181246     Dec 31 2002 19:05:56  securedesktop-asa-
  120  398305      Dec 31 2002 19:06:10  sslclient-win-
    6  8192        May 26 2010 15:55:16  crypto_archive
  121  6163744     May 26 2010 15:56:50  asdm-508.bin
  123  6889764     Jun 11 2010 01:53:16  asdm-602.bin
  124  15943680    Jun 15 2010 07:41:26  asa831-k8.bin
  125  14240396    Jun 15 2010 07:42:52  asdm-631.bin
    3  8192        Jun 15 2010 07:47:40  log
  126  2684        Jun 15 2010 07:47:50  7_0_8_0_startup_cfg.sav
   13  8192        Jun 15 2010 07:47:56  coredumpinfo
   14  43          Jun 15 2010 07:47:56  coredumpinfo/coredump.cfg
  127  1158        Jun 15 2010 07:47:56  upgrade_startup_errors_201006151147.log
  128  8192        Mar 10 2011 10:41:56  tmp
  129  14812604    Jan 21 2011 22:13:02  asdm-635.bin
  130  15962112    Jan 21 2011 22:13:42  asa832-k8.bin
  131  89          Mar 08 2011 16:25:48  dap.xml
  135  5190144     Mar 14 2011 15:04:21  csd-3.5.2008-windows-k9.msi
  136  12998641    Mar 14 2011 15:06:27  csd_3.5.2008-k9.pkg
  141  5278629     Mar 14 2011 16:32:57  anyconnect-dart-win-2.5.2019-k9.pkg
  142  3866773     Mar 14 2011 16:39:33  anyconnect-win-2.5.0217-k9.pkg
  143  4686889     Mar 14 2011 17:01:12  anyconnect-win-2.5.2019-k9.pkg

Accepted Solution

First Last earned 0 total points
ID: 35416676
Turns out the MD5 check sum was being changed as the file was downloaded. I downloaded the file using a different connectioned, saved it locally to a USB stick, then I was able to load it into the ASA without and issues. Thank you everyone!

Author Closing Comment

by:First Last
ID: 35872699
Cisco Support was able to find a resolution.

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question