LDIFDE Import AD Account and Set Password

Hello I am trying to use LDIFDE to import a user account and set the user's password. I am sucessful in importing the user but I do not understand the syntax for setting the user's password in the add step.

Here is what I am using to sucessfully create the user account. (account is created with blank password and is flagged as disabled due to no password)

--------------------------------------------------------------------------------

dn: CN=user0234567,OU=2010,OU=Students,OU=Customers,DC=mydomain,DC=edu
changetype: add
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: user
cn: user0234567
sn: Doe
description: 123456
givenName: John
initials: E
displayName: John Doe
name: user0123456
accountExpires: 129472308000000000
sAMAccountName: 0123456
userPrincipalName: user0123456@witcc.edu
objectCategory: CN=Person,CN=Schema,CN=Configuration,DC=mydomain,DC=edu

--------------------------------------------------------------------------------------


I would like to have the user account enabled and set the password to a static string of something like     USER12345

Can someone tell me what I need to add to this ldf file to accomplish this?

thank you!
miteldatanetAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
miteldatanetConnect With a Mentor Author Commented:
We ended up using DSADD and a CSV to accomplish what we need.
0
 
Justin OwensITIL Problem ManagerCommented:
You have this Question in two Zones... Are you using AD 2003 or AD 2008, and what is the OS you are using to do the import?
0
 
Justin OwensITIL Problem ManagerCommented:
In your Example above:

dn: CN=user0234567,OU=2010,OU=Students,OU=Customers,DC=mydomain,DC=edu
changetype: modify
replace: unicodePwd
unicodePwd::IgBuAGUAdwBQAGEAcwBzAHcAbwByAGQAIgA=

Source: http://support.microsoft.com/kb/263991

If memory serves, you have to create the account first, then set the password, then undisable it.  The item for lockout is, if memory serves, useraccountcontrol, but I cannot remember how to change it from disabled to enabled.

DrUltima
0
 
miteldatanetAuthor Commented:
could not get ldefide to import password.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.