• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1393
  • Last Modified:

SBS2003 Effective Permissions are full but the user can't save files to home directory

I have a user who has a home directory on one of our servers, they appear to have full permissions to the directory and the effective permissions show full but they get a permission error when they try and write a file out to the drive in 2010 word.

If i move their home directory from the home share to the root of D drive and share them directly they can access and write fine. There are many users in the HOME share but this user is the only one having problems saving files.

Anyone have something that might help? The problem appears to be the Home directory above the users directories but that is the same for all users yet only one has a problem!

Help!
0
dpcsit
Asked:
dpcsit
1 Solution
 
AustinComputerLabsCommented:
This one is inheriting permissions from above like the rest?
0
 
vervenetworksCommented:
Check to see who is the Owner of the folder.  A lot of Microsoft's default folder use the CREATOR OWNER permission.  Check the "Replace owner on subfolders and files" box, and apply to propagate.
0
 
dpcsitAuthor Commented:
Yes they are all setup to inherit from the parent home directory that is the share.

Owner is administrator, not the user and creator owner is not part of the security settings for the directory that is failing and also any of the directories that are working fine.

One thing of worth I think might play a part in this the home share is setup with the everyone as read rights only and authenticated users are setup with read and change ability.

I have to wonder if the user is somehow not showing as an authenticated user and that is somehow affecting the access.

The user seems to authenticate fine though and has access to any of the other shares and can right to them fine, but authenticated user is not part of the security of those shares.

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
dpcsitAuthor Commented:
that should be write etc. sorry been a long day!
0
 
vervenetworksCommented:
Can you verify that the other user's home folders have the same permission, since they are working properly.  The user will be in the authenticated users group, however, the everyone permission would most likely block write access.  I typically use Authenticated Users over Everyone, and not both together.  Authenticated Users will encompass any AD or local SAM groups/users.  
0
 
vervenetworksCommented:
You could also try pulling off all permission to the folder, and re-inheriting, in case they got overwritten somehow.
0
 
dpcsitAuthor Commented:
I want to say I did not set this up ;) but it's worked fine except this one user, who has been having issues, installing office 2010 finally stopped the work around they were using to get the data out.

All sub-directories are the same permissions and they all show fill rights for the user at the file level. I hate to change the home directory settings yet in case I dig a the hole deeper, I will try setting up a testhome directory to re-create the current settings and then pull the everyone rights away.

That way I know it fixes it instead of finding out the hard way and breaking the rest of them.
0
 
vervenetworksCommented:
Here's a thought....rename the folder, and have the user logoff/logon.  The process will create a new folder with the appropriate rights, assuming the parent folder was setup correctly.  Then copy the data from one folder to the new folder.
0
 
dpcsitAuthor Commented:
That's an excellent idea! I will give it a try and see what happens.
0
 
dpcsitAuthor Commented:
I actually moved them to another separate location and created a share for them alone to get around the issue. But the idea is a valid one to test.
0
 
ajdratchCommented:
I had this same problem and thought I should share my solution. The workstation was Windows 7 and server was SBS 2008. I discovered the problem was with the offline cache files. I reinitialized it and all was good.

Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CSC\Parameters
Create new REG_DWORD key with name FormatDatabase with value of 1
Reboot
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now