[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Why won't my 1900 series CISCO router connect to the internet

Posted on 2011-03-14
10
Medium Priority
?
1,218 Views
Last Modified: 2012-05-11
We just got a 1900 series Cisco router and after setting it up, I can see the network with it and ping it, but cannot get to the internet from it.  Here is the config:
Using 1500 out of 262136 bytes
!
! Last configuration change at 01:13:30 UTC Mon Mar 14 2011
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CasinOmahaRouter
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password @!
no aaa new-model
!
!
no ipv6 cef
no ip routing
no ip cef
!
ip name-server 207.5.120.16
ip name-server 207.5.120.17
ip name-server 66.37.236.22
!
multilink bundle-name authenticated
!
license udi pid CISCO1921/K9 sn FGL15042EK1
!
redundancy
!
interface GigabitEthernet0/0
 description To Internet
 ip address 10.236.15.??? 255.255.254.0
 ip nat outside
 ip virtual-reassembly
 no ip route-cache
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0/1
 description XXX Network
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 duplex auto
 speed auto
 no mop enabled
interface Serial0/0/0
 no ip address
 no ip route-cache
 shutdown
 no clock rate 2000000
 !
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0.0 10.236.14.1
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any!
control-plane
line con 0
line aux 0
line vty 0 4
 password
 login
!
scheduler allocate 20000 1000
end

And these are the settings for our current router:
ip address 10.236.15.???
subnet mask 255.255.254.0
gateway 10.236.14.1
dns  207.5.120.16
Any help would be very much appreciated!!  
0
Comment
Question by:coughlin74
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 4

Expert Comment

by:bjove
ID: 35133655
Enable routing:
Router(config)#ip routing
0
 

Expert Comment

by:rodrigo01
ID: 35133658
do you created the Vlan?
0
 

Author Comment

by:coughlin74
ID: 35133915
Routing is enabled now. I did not create a Vlan.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 4

Expert Comment

by:bjove
ID: 35134081
Can you ping gateway 10.236.14.1 from the router?
Try to tracert to some public address from some PC on 192.168.1.0 network. What is the output?
0
 

Author Comment

by:coughlin74
ID: 35134423
The Ping works at 80%, tracert fail with error message unable to resolve taget system name.

current config

ip name-server 207.5.120.16
ip name-server 207.5.120.17
ip name-server 66.37.236.22
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FGL15042EK1
!
!
interface GigabitEthernet0/0
 description To Internet
 ip address 10.236.15.xxx 255.255.254.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0/1
 description CasinOamha Network
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 no mop enabled
 !
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Serial0/0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
!
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 35135001
Remove this route
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

The default route must point to the next hop IP and *not* the interface

ip route 0.0.0.0 0.0.0.0 10.236.15.?

Since 10.236.15.x is a private network, I assume that the next hop device already has Internet access on some public IP address?

0
 
LVL 4

Assisted Solution

by:bjove
bjove earned 1000 total points
ID: 35136917
What do you get if you try:
tracert 207.5.120.16
from  from some PC on 192.168.1.0 network?
What is the output if you try:
ipconfig /all
on the PC?
What is the output of
show ip route
on the router?
0
 

Author Comment

by:coughlin74
ID: 35140791
Our internet service has been down all morning, I will get you some answers as soon as possible. Before I disconnect the internet to test I have to let them catch up.
0
 

Author Comment

by:coughlin74
ID: 35143509
Our Linksys current settings
10.236.15.xx 255.255.254.0
Gateway 10.236.14.1

Config file
hostname CasinRouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$j/Mk$ecEfgreZtnpX1CSVDpqBp1!
no aaa new-model
!
!
!
!
no ipv6 cef
ip source-route

ip name-server 207.5.120.16
ip name-server 207.5.120.17
ip name-server 66.37.236.22
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FGL15042EK1
!
!
!
redundancy
!
interface GigabitEthernet0/0
 description To Internet
 ip address 10.236.15.xxx 255.255.254.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0/1
 description CasinNetwork
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 no mop enabled
 !
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.236.14.1
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any



Ipconfig/all shows

Ip 192.168.1.251 255.255.255.0
D.Gateway 192.168.1.1
DNS 192.168.1.252
        192.168.1.1

gateway of last resort is 10.236.14.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.236.14.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.236.14.0/23 is directly connected, GigabitEthernet0/0
L        10.236.15.165/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.1/32 is directly connected, GigabitEthernet0/1

0
 

Author Closing Comment

by:coughlin74
ID: 35143627
The router is now working after I typed that last message. This was the longest I had it on the network the entire time I was testing it. I also changed the IP route as you can see on that last config. Not sure why it started working but it’s up and going. Thanks for all your help.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question