Solved

Solaris 10 cdrom boot

Posted on 2011-03-15
17
2,751 Views
Last Modified: 2013-12-28
Hi

I need help in setting up Solaris 10, I was given this solaris server to install. following is the details

Sun Enterprise 420R (2 X UltraSPARC-II 450MHz), No Keyboard
OpenBoot 3.23, 3072 MB memory installed, Serial #16238376.
Ethernet address 8:0:20:f7:c7:28, Host ID: 80f7c728.

I downloaded the ISO sparc from oracle site and burned the ISO into DVD, following is the contents of the DVD, i listed this from a PC

E:\>dir
 Volume in drive E is SOL_10_910_SPARC
 Volume Serial Number is B3F7-7ED1

 Directory of E:\

03/02/2010  04:28 AM                68 .CDTOC
08/12/2010  02:11 AM    <DIR>          .INSTALL
08/12/2010  02:11 AM                 0 .INSTALL_CONFIG
03/02/2010  04:28 AM               439 .SLICEMAPFILE
08/12/2010  02:11 AM    <DIR>          BOOT
05/27/2010  03:39 AM             7,625 COPYRIGHT
07/22/2010  06:34 AM             1,797 GPL_LGPL_SOURCE_OFFER.TXT
08/12/2010  02:02 AM               257 INSTALLER
08/12/2010  02:11 AM    <DIR>          PLATFORM
08/12/2010  02:11 AM    <DIR>          SOLARIS_10
04/09/2010  03:29 AM                21 _VOLUME.INF
08/12/2010  02:03 AM                28 _VOLUME_INF.1
08/12/2010  02:03 AM                28 _VOLUME_INF.2
08/12/2010  02:02 AM                23 _VOLUME_INF.3
08/12/2010  02:02 AM                23 _VOLUME_INF.4
08/12/2010  02:02 AM                23 _VOLUME_INF.5
              12 File(s)         10,332 bytes
               4 Dir(s)               0 bytes free

E:\>
 
I am getting bad magic number when trying to do "boot cdrom"

{1} ok boot cdrom
Boot device: /pci@1f,4000/scsi@3/disk@6,0:f  File and args:
Bad magic number in disk label
Can't open disk label package

Can't open boot device

{1} ok probe-scsi
Target 0
  Unit 0   Disk     HITACHI DK32EJ36NSUN36G PQ08
Target 1
  Unit 0   Disk     FUJITSU MAJ3364M SUN36G 0804
Target 6
  Unit 0   Removable Read Only device    TOSHIBA DVD-ROM SD-M14011007

I have tried to re download the file from oracle and burned into another DVD, however still the same error.

I tried the same server using Solaris 9 CDROM and it works on boot cdrom. what could the possible problem here?
0
Comment
Question by:AntonVQ
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 4
  • +1
17 Comments
 
LVL 47

Expert Comment

by:dlethe
ID: 35136053
Looks like you didn't burn it right.  You perhaps copied files, rather than make a bootable image
0
 
LVL 47

Expert Comment

by:dlethe
ID: 35136067
(As a test, make an image of the Solaris 9 using same technique, see if the disk works, then you will know if solaris 10 has an issue, or your cd burning software, or if it is operator error)
0
 
LVL 9

Expert Comment

by:amolg
ID: 35137355
Burn it as a bootable image.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 16

Expert Comment

by:Joseph Gan
ID: 35142289
Can you please try:
ok> boot cdrom -s
0
 

Author Comment

by:AntonVQ
ID: 35144216
Hi

I am aware how to make a bootable DVD from ISO, i have done this with other OS like CentOS, OpenSUSE successfully. I do not think there is any issue with my burning software unless there is different way to burnt Solaris ISO images.... Btw I use NERO.

As mentioned in my post, the downloaded file name is sol-10-u9-ga-sparc-dvd.iso, when burned into DVD i am getting a list of files as stated above. with this I believe it is not a copy and paste method. correct me if i misunderstood.

I tried boot cdrom -s, it returned the same error.

Is anyone out there has a working Solaris 10 U9 Sparc DVD? kindly list me the file contents, this way i can compare to see what I am missing on my current DVD

thank you for the response so far.
0
 
LVL 16

Expert Comment

by:Joseph Gan
ID: 35144269
My Solaris 10 (11/06) Sparc DVD dosen't have "BOOT" directory
0
 
LVL 16

Expert Comment

by:Joseph Gan
ID: 35144285
And dosen't have "PLATFORM" directory either.
Two <DIR> I have were:
<DIR>   .INSTALL
<DIR>   SOLARIS_10
0
 
LVL 47

Expert Comment

by:dlethe
ID: 35144355
I don't use nero, but I'm betting there are some obscure settings to look at.  SPARC cpus are not little-endian, and that can throw off some software.

Here are a bunch of articles on how to do it, and some work-arounds

http://unixforum.info/forum/index.php?topic=4658.0
0
 
LVL 16

Expert Comment

by:Joseph Gan
ID: 35144361
Also try to use DVD-R if haven't do so.
0
 

Author Comment

by:AntonVQ
ID: 35145879
I have been using DVD-R, I even tried other burning software, but still the same.
I tried looking for Solaris 10 in CD instead of DVD but could not find. Reason I am suspecting my DVD ROM not able to read content of the DVD. Does Solaris 10 has CD version?

Alternatively, is there a command to check if my DVD ROM able to read my DVD-R from ok> prompt? probably listing the contents or similar.

Thank you

dlethe, this thread is not available anymore http://forums.sun.com/thread.jspa?threadID=5349350
0
 
LVL 9

Expert Comment

by:amolg
ID: 35147342
Try these two options,

1) The option you want is "File\Record Disc from Image" and then click "Burn". Try buring onto  DVDR media at speed 4X. The iso image is exactly what's needed for a bootable DVD and if it is transferred to the DVD as an image the result will be bootable.

2) It looks like the cdrom alias may be the problem.  

Try below,

ok show-disks - chose the letter for the cdrom drive
ok nvalias cdrom2 [Ctrl] + [y] to paste the cdrom path.
ok reset-all
ok boot cdrom2

0
 
LVL 47

Expert Comment

by:dlethe
ID: 35147490
Well it is still obvious that you didn't burn the disk right, so some alternatives
  * use cdrecord (it is free) or a mac  Personally I use the native program under Mac OSX called disk utility to burn ISO images, and never have a problem
  * contact Nero, or worse, do something unnatural and utterly unheard of regarding Nero, called reading the documentation.  I have to believe that this software can do the job.
  * set up tftp under windows so you can do this over the network
 
0
 

Author Comment

by:AntonVQ
ID: 35153807
hi amolg,
yes, i have been using the lowest 4x as i saw this on other forum, still no luck. i tried changing alias
{1} ok show-disks
a) /pci@1f,4000/scsi@3,1/disk
b) /pci@1f,4000/scsi@3/disk
c) /pci@1f,4000/ebus@1/fdthree@14,3023f0
q) NO SELECTION
Enter Selection, q to quit:
i tried a, b and c but still cannot boot.

hi dlethe,
i got a macbook, i check the md5 of the downloaded iso.zip it matches with Oracle site, so the file is OK. I burned using Mac disk utility. result still the same -
Bad magic number in disk label
Can't open disk label package
Can't open boot device

do you have guide on how to boot of tftp from solaris? I have a window tftp server in operation

thank you all for the help so far...

0
 
LVL 47

Expert Comment

by:dlethe
ID: 35153869
I know this is redundant, but humor me ..

Get to the O/S prompt, put in a DVD, and enter below to burn the ISO image properly.
hdiutil burn sol-10-u9-ga-sparc-dvd.iso

Yes, it is THAT simple on a mac.  Who needs a a GUI ;)

Thinking outside the box  ...

Have you verified that this version of solaris even runs on your system with the current BIOS/Firmware patch level?    Go to the support site and check all the firmware (in addition to openboot)

0
 

Author Comment

by:AntonVQ
ID: 35163900
i tried using terminal and run the hdiutil.. however I am still not getting through. same error when booting the from the new dvd
Bad magic number in disk label
Can't open disk label package
Can't open boot device

I do not have much info on the box, i can see following during boot up
Sun Enterprise 420R (2 X UltraSPARC-II 450MHz), No Keyboard
OpenBoot 3.23

Based on this, the oracle site say it is supported to run Solaris 10
http://www.sun.com/bigadmin/hcl/data/systems/details/1809.html 

I am installing Solaris 9 on the server now, once done, i will insert Sol10 dvd and check if the dvdrom can read those.

Let me know if you guys have more idea into this.

thank you.
0
 
LVL 47

Accepted Solution

by:
dlethe earned 500 total points
ID: 35164059
I've run into situations before were a system did not boot solaris.  First, go to the sun support site, and search for your machine model.  Make 100% sure that you update all the firmware, including the boot firmware & firmware on the DVD (if applicable).

There is more than one image for the "bios".  The OpenBoot is just one of them.  I have also run into situations where I had a non-sun CD and it would not boot (but don't have a non-Sun DVD so never looked at that)
0
 

Author Comment

by:AntonVQ
ID: 35360624
it turns out that my dvd rom firmware doesn't support dvd. i have to upgrade its firmware.

thanks all for the help
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question