• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 869
  • Last Modified:

Error exporting mail from exchange2010

I am trying to export mails but getting the error attached.

Your help is highly appreciated.

Thanks

screen.docx
0
MAS (MVE)
Asked:
MAS (MVE)
  • 19
  • 11
  • 4
3 Solutions
 
AkhaterCommented:
as a start the pst folder path a UNC not a local disk
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I tried with UNC but it is the sam error
0
 
AkhaterCommented:
Ok

Did you follow the tutorial i gave you ? Can you double check you did all steps?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
MAS (MVE)Technical Department HeadAuthor Commented:
I did not get any tutorial or may be I missed,  not sure
Anyway please give me again
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I am getting this error

The term 'New-MailboxExportRequest' is not recognized as the name of a cmdlet
0
 
Tony JLead Technical ArchitectCommented:
Make sure you run the Exchange Management Shell and NOT PowerShell.
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
screenshot attached
error.docx
0
 
Tony JLead Technical ArchitectCommented:
You need to put Exchange 2010 SP1 on for that command to work.
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I am downloading SP1 now.

What is the command to export all the mailboxes
0
 
Tony JLead Technical ArchitectCommented:
Take a look here - he's built a script that should do it:

http://www.stevieg.org/tag/new-mailboxexportrequest/
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
upgraded to SP1 but no luck
0
 
AkhaterCommented:
please when you say "no luck" what does it mean exactly ? what steps did you do ? did you follow my tutorial ? what errors you had ?
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
The sam error as in post #35146840
0
 
AkhaterCommented:
You mean new-mailboxExportRequest is not recognized ????

Did you follow my tutorial ? did you create the management group and added the user you are useing to it ?

did you logoff logon after doing that ?
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I added administrator to the group.
restarted server after upgradation.
0
 
AkhaterCommented:
please run this and give me the output

New-ManagementRoleAssignment -Name "Import Export Mailbox Admins" -SecurityGroup "Mailbox Support" -Role "Mailbox Import Export"
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Couldn't find a security group with this identity: "Mailbox Support".
    + CategoryInfo          : NotSpecified: (0:Int32) [New-ManagementRoleAssignment], ManagementObjectNotFoundExceptio
   n
    + FullyQualifiedErrorId : CCF8A316,Microsoft.Exchange.Management.RbacTasks.NewManagementRoleAssignment
0
 
AkhaterCommented:
Go to your Active Directory users and computers and create a Security Universal group called "Mailbox Support"

Check my tutorial for more info

and run the command again
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Active Directory operation failed on Exchange2010.nsportq8.local. The object 'CN=Import Export Mailbox Admins,CN=Role A
ssignments,CN=RBAC,CN=NSPORTQ8,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=nsportq8,DC=local' already exists.
    + CategoryInfo          : NotSpecified: (0:Int32) [New-ManagementRoleAssignment], ADObjectAlreadyExistsException
    + FullyQualifiedErrorId : 1B051A9B,Microsoft.Exchange.Management.RbacTasks.NewManagementRoleAssignment
0
 
AkhaterCommented:
remove-ManagementRoleAssignment "Import Export Mailbox Admins"

New-ManagementRoleAssignment -Name "Import Export Mailbox Admins" -SecurityGroup "Mailbox Support" -Role "Mailbox Import Export"
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I ran both the commands and logged off and tried but no luck
same error as before
The term 'New-MailboxExportRequest' is not recognized as the name of a cmdlet
0
 
Tony JLead Technical ArchitectCommented:
Can you post a screenshot of the error again?
0
 
AkhaterCommented:
Can you take a breath please we are not done yet


now go to AD users and computers and add the account you are using and add it to the "Mailbox Support" group then logoff logon
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Screenshot attached

Administrator is already added to the mailbox support group.
error.docx
0
 
AkhaterCommented:
try export-mailbox command please
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
This is error when I tried with 'Export-mailbox -identity administrator -PSTFolderPath c:\administrator.pst'

Error was found for Administrator (Administrator@nsportq8.com) because: The operation failed., error code: -2147467259
    + CategoryInfo          : InvalidOperation: (0:Int32) [Export-Mailbox], RecipientTaskException
    + FullyQualifiedErrorId : B876DE13,Microsoft.Exchange.Management.RecipientTasks.ExportMailbox
0
 
AkhaterCommented:
then you don't have SP1 installed, you need SP1 to use New-MailboxExportRequest installe xchange 2010 sp1
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Now getting this error any idea.

Attached
error.docx
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I found a solution I have installed windows7-x64  and installed only management tools and powershell.

Many thanks for your continous support.
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I found the right solution. We have to add a new user, add that user to the new group created and login to the server as that user and tried.

it worked for me. I tried with administrator account.

please make this as another assissted solution
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
I found the right solution. We have to add a new user, add that user to the new group created and login to the server as that user and tried.

it worked for me. I tried with administrator account before. That could be the reason it did not worked for me. Administrator was a member of that group. eventhough it is not worked for me.

please make this as another assissted solution
0
 
MAS (MVE)Technical Department HeadAuthor Commented:
Installed and found a solution for the time being.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 19
  • 11
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now