Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 302
  • Last Modified:

Linked Server in Sql server

I have two instances of Sql server - Sql 2005 and Sql 2000.  Sql 2005 is configured to work under Windows authentication  running under Domain account.
and Sql2000 is configured for windows and Sql authentication and running under system account.

I have configured sql2000 as linked server under sql 2005 instance. I am able to run the stored procedure stored in sql 2000 instance. but when i try to insert locally from linked server procedure i am getting the following error.

OLE DB provider "SQLNCLI" for linked server "blrds" returned message "The partner transaction manager has disabled its support for remote/network transactions.".
Msg 7391, Level 16, State 2, Line 1
The operation could not be performed because OLE DB provider "SQLNCLI" for linked server "blrds" was unable to begin a distributed transaction.

Can some expert help me to overcome this error

Thanks in advance


0
venkataramanaiahsr
Asked:
venkataramanaiahsr
1 Solution
 
kamindaCommented:
I think this will help you to sort out your problem

http://support.microsoft.com/kb/306212
0
 
k_murli_krishnaCommented:
Please go through these:

The partner transaction manager has disabled its support for remote/network transactions
http://social.msdn.microsoft.com/Forums/en-US/adodotnetdataproviders/thread/7172223f-acbe-4472-8cdf-feec80fd2e64

MSDTC Troubleshooting
http://www.sqlwebpedia.com/content/msdtc-troubleshooting
0
 
venkataramanaiahsrAuthor Commented:
I followed the instructions mentioned in the link http://www.sqlwebpedia.com/content/msdtc-troubleshooting in the sql2005 server .

i am trying to run the qry from sql 2005 server qry analyzer  to the linked server (sql2000 server) . Still the same problem . Do i have to do the same changes in Sql 2000 server also.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Darran BrownDBACommented:
Hi,
You shouldn't need run any queries just yet, i've just had to change the same settings yesterday. k_murli_krishna has the correct link:
http://social.msdn.microsoft.com/Forums/en-US/adodotnetdataproviders/thread/7172223f-acbe-4472-8cdf-feec80fd2e64
1.      Go to "Administrative Tools > Component Services"
2.      On the left tree, go to "Component Services > Computers > My Computer
3.      Right click on "My Computer", select "Properties"
4.      Select "MSDTC" tab
5.      Click "Security Configuration"
6.      Check "Network DTC Access", "Allow Remote Client", "Allow Inbound/Outbound"

It will be your 2000 server that needs changing but check both. You may get a couple more erros when you try and use the linked server but we can sort those as they occurr, just post any new errors, it depends how your server is set up.
0
 
venkataramanaiahsrAuthor Commented:
Thanks Mr_B.   Actually MSDTC change mentioned in the link http://www.sqlwebpedia.com/content/msdtc-troubleshooting to be done in both the servers. After doing these changes , my problem got resolved. I have given No authentication required at both ends under MSDTC security configuaration.  Is it Ok or no authentication  will cause any security issues?


0
 
Darran BrownDBACommented:
Hi
It's a bit hard to confirm without knowing your exact set up but ideally you want mutual Authentication.
If the msdtc security settings weren't set before we could say that nothing else is using them but if you have anything else on the servers apart from SQL you might want to double check. I'm also presuming there in the same domain.

0
 
venkataramanaiahsrAuthor Commented:

Thanks  MR_B .your solution worked. I am really sorry for not accepting the solution earlier as i had tied up with some other priority activities
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now