Apache - IE problem

I have recently enabled https on one of my sites. Since then while accessing the site, IE8 is throwing a message - "Do you want to veiw only the webpage content that was delivered securely?" If I press No, site works fine. If I press yes, login page shows but unable to login.
Site is working fine in Mozilla.
Why IE is taking Non secure content seperately? I cant ask all my users to press "No" when it throws a warning message. So Can I solve this at Apache?
RazAsked:
Who is Participating?
 
DonConsolioCommented:
You possibly mixed secure and insecure elements on your web page.
Possibly some image(s) are loaded via http://.

possible fix:
http://blog.httpwatch.com/2009/04/23/fixing-the-ie-8-warning-do-you-want-to-view-only-the-webpage-content-that-was-delivered-securely/
0
 
edbedbCommented:
I believe you can fix this by changing all the "http:" links to "https:"
0
 
RazAuthor Commented:
I have already changed them. The problem arises only when I access the application through https. On http it is working fine.
0
 
RazAuthor Commented:
I asked how to solve this at backend that is at apache. How to make the content secure. The solution provided is to disable the http/https content categorising feature in IE which i already know.
0
 
DonConsolioCommented:
Check your web pages for absolute links to http://.... URLs, check if the pages load content from different servers via http:// (e.g. pictures, media, flash content, etc.)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.