Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Folder Permissions - Denied

Posted on 2011-03-15
3
Medium Priority
?
674 Views
Last Modified: 2012-05-11
Experts,

We have a File Server running Windows Server 2008. There is a folder located on a data drive that is shared to 2 users, these users are working fine.

When adding a 3rd user we are being denied access on specific files even when granting full control, and inheritance, we have even tried giving the user ownership. There are too many files to go in manually and re create the permissions. I need to remove all permissions and re create them from new. Can anyone advise on best practise to do this?

0
Comment
Question by:ncomper
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 8

Accepted Solution

by:
Acosta Technology Services earned 1000 total points
ID: 35137399
I would start from the root where the inheritable permissions are propagating from and remove that checkbox (copy permissions when doing so).  After that, I would go to the lowest level that seems to have an issue and change the directory permissions to only contain Domain Admins (or an account of your choosing).  Allow those permissions to inherit to it's subdirectories and then add back in the required permissions for each directory at that time.
0
 
LVL 70

Assisted Solution

by:KCTS
KCTS earned 1000 total points
ID: 35137693
Make sure that there are no DENYs set - these will override any other permissions - use the Effective permissions tab to check the users permissions.

BTW its bad practice to give permissions to users - put the users into a security group, then grant permissions to the group - that way you can give others permissions just by adding them to the group (or remove their permissions be removing them from the group)
0
 
LVL 5

Author Closing Comment

by:ncomper
ID: 35191744
Defaulted the setting on Share to Full on Authenticated users.

Within the Security permissions removed all none required users/Groups. Added the single group with full access and propagate to child objects
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question