Setup active directory as a role, now what?

After I setup the role on this server 2008, I get this event:

The local domain controller could not connect with the following domain controller hosting the following directory partition to resolve distinguished names.

Am I suppose to do something else? What about the DNS, do I change the static dns to itself?

Also you should know that in order for a workstation to be added to the domain I have to manually set the dns on that workstation to 192.168.1.2 (Server).
cnl83Asked:
Who is Participating?
 
Stelian StanConnect With a Mentor Network AdministratorCommented:
Now you should run: dcpromo

Open a command prompt and run DCPROMO
0
 
cnl83Author Commented:
I did run dcpromo
0
 
Stelian StanConnect With a Mentor Network AdministratorCommented:
This is the only one DC in your domain?
If YES in that case your TCP/IP config should look like:
IP: 192.168.1.2
GW: 255.255.255.0
DNS1: 192.168.1.2
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LeDaoukCommented:
if you ping the domain name do you get the right server IP?
also check the gateway!
and while joining to domain be aware of .com .org .net issue
0
 
cnl83Author Commented:
If I changed the DNS to itself, do I need to change anything on the router?  The router is set to obtain everything automatically. The router is also my dhcp server btw.
0
 
cnl83Author Commented:
Yes when I ping the domain, I get the correct ip.
0
 
LeDaoukCommented:
check firewall settings
0
 
cnl83Author Commented:
Ok, so one thing im confused about. If I change the dns on my server to itself, then how will it get out on the internet for various reasons?
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
You need to make the server point to itself for DNS and add a forwarder to deal with external DNS lookups (in the DNS console on the DC)
0
 
cnl83Author Commented:
Forgive me for being so naive, as I have not setup a dns server before. I am using the wizard to create a forwarder. It ask me if my server maintains the zone or my isp. I would imagine that my isp maintains the primary lookup zone, but Im not certain.
0
 
cnl83Author Commented:
Once I create the forward lookup, and change the dns to itself, then do I need to change something on the router?
0
 
cnl83Author Commented:
Ok, so it would not let me add that zone, because it already exist. So i went into the properties of the existing forwarder. Should I enter my isp dns 1 and dns 2 in the wins and name servers tab?
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
There should be no need to create a zone  - the only zone you need to have is the zone for your own domain
Right click on the DNS server tab, and enter your router IP as the forwarder - see http://www.petri.co.il/configure_dns_forwarding.htm
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
DONT change the Preferred and Alternate DNS server settings in the TCP/IP dialog on your network connection - the only IP here should be its own IP
0
 
cnl83Author Commented:
DNS SettingsThere is the screen shot of my properties. This is something that server 2008 configured, because I never entered my isp dns 1 and dns 2.

Now you say "dont alter your dns on my network connection". So as it is right now, my dns on my connection is
68.105.28.16
68.105.29.16

I should not change this to 192.168.1.2  (Server ip) ?
0
 
NavdeepCommented:
If you want i can login to your DC and fix up everything for you.
0
 
Brian PiercePhotographerCommented:
If those two IPs are the DNS servers of your ISP then thats fine

The  DNS server settings on the network connection itself (not the setting in the DNS console), needs to point to your own server.
0
 
cnl83Author Commented:
Ok, im about to switch my dns settings on my connection. Nothing needs to be configured on my router correct?
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
no - the router is fine -  just make sure the the default gateway setting on the network card points at the router and that the server points to itself for DNS
0
 
cnl83Author Commented:
I just went to change my adapter settings and dns is already 127.0.0.1

I suppose server 2008 is a self doing system now. Ok, well then at least I know how this whole thing works now.
0
 
Brian PiercePhotographerCommented:
127.0.0.1 is Ok
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.