Visual Studio 2010 doesn't run old .netframework versions

Dear,

I installed successfully Visual Studio 2010 , I have installed .netframework 3.5 , 3 , 2 as well.
after Installation, I try to open old project run on .netframework 2 and I want to keep this version as well.
but I get this error message:
.NETFramework, Version=v2.0", which is not installed on the machine. You must download the framework as well as .NET Framework 3.5 in order to open and build this project



I checked the Add/Remove programs and I find both 3.5 & 2 .netframework are still installed

please help to solve this problem

thank you,
omarwaAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Carl TawnConnect With a Mentor Systems and Integration DeveloperCommented:
VS2010 has an issue recognising older versions of the framework that aren't fully up-to-date. From that screen shot you don't appear to have 3.5 SP1 installed. Try running a Windows update and seeing if it picks it up.
0
 
hesCommented:
Which order did you install the frameworks ? I think you have to install them 2 then 3 then 3.5
0
 
omarwaAuthor Commented:
Yes, I installed them in order
install 3.5 netframwork which include 2
then I installed Visual Studio
find a screen to my programs list


Programs-list.gif
0
 
omarwaAuthor Commented:
I used Windows Update and downloaded
Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0

Solution is perfectly solved the problem
0
All Courses

From novice to tech pro — start learning today.