Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6668
  • Last Modified:

W3WP.exe is Causing Issues with Exchange and Activesync

Good afternoon!

   I have been Dealing with this problem all week and have not found a resolution yet. So I need Help.

What I have is a SBS 2003 with SP2 server. I have about 40 users and about a Dozen Execs using Iphones and or Androids, half of which is complaining about sync issues.

The server is up to date with the Updates and patches, Exchange is SP2

When I look at my event log I see Active Sync errors (3014, 3007, 3005). I have increase the keep alive on the default site to help with the 3005 errors.


when I look at the processes running I see that W3WP.exe is running about 75%-99 cpu time with 300K memory.

I have also found which threads that the w3wp.exe is running which is the Exchange Application pool PID 5348.
I have looked into the Application pool settings and tweaked some thing but it didnt make much difference at all so I put them back to the default settings.

I have applied KB970103, 971439, 912586

As I stated, some iphones and androids are having sync issues. I have two users that stated when they reply to an email it sends two - three messages.
I have noticed aswell that when the CPU is full that exchange starts to slow down sometimes I have to run IISREST to stablize everything.


  Thanks


Thanks for your help
0
meko72
Asked:
meko72
  • 25
  • 23
  • 2
  • +2
1 Solution
 
waleedaCommented:
0
 
meko72Author Commented:
Thanks for the Link, I have already found the threads that the process is using which is the Exchange Application pool .
0
 
waleedaCommented:
so my link was useful for you :)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
meko72Author Commented:
I went to the server and the CPU was low, and no one was complaining about emails so I sent a test email via OWA and nothing. I looked at the Event log same 3007 but I saw in the system log that there was a event 1010. (a process serving application pool, exchange application pool failed to respond to ping.)
Went to console and IISREST all emails coming through now.
0
 
Alan HardistyCo-OwnerCommented:
When did you install SP2 for Exchange?  Quite often, reinstalling it helps solve a lot of Exchange problems!

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=535bef85-3096-45f8-aa43-60f1f58b3c40&displaylang=en
0
 
meko72Author Commented:
It was last spring that is was installed.  Do I need to unistall and reinstall?

The problem that I am having is that the woker process( W3WP.exe) that contols the Exchange pool is Very High in CPU with over 300K - 475K in memory and It Killing Active sync Hense the 3005, 3007, 3014  errors in my event logs
0
 
Alan HardistyCo-OwnerCommented:
No - no need to uninstall - just reinstall it.

No promises - but it might just resolve your issue.
0
 
ash007Commented:
You can install update from Apple on iphones:

http://support.apple.com/kb/TS3398 
0
 
Alan HardistyCo-OwnerCommented:
That's relevant if the iPhones are still using iOS 4.0 but not if they are up-to-date with anything higher than 4.0.

Good idea ash007.
0
 
meko72Author Commented:
Thanks Ash for the link. With the CPU I tryed the update on one phone and the problem still is there. The W3WS.exe process is running the cpu to 95-99% which is affecting the Active sync on all phone from Iphone, Blackjack and android.
I had one exec that sent me an email and it came to me 6 times.
0
 
Alan HardistyCo-OwnerCommented:
Any joy with SP2 re-install yet?
0
 
meko72Author Commented:
I am going to reapply SP2 at lunch. I tryed last night and I got an error stating "An earlier version of the intelligent message filter has been Detected" I found KB935916 to work around it. I will keep you posted..

  Thanks!
0
 
Alan HardistyCo-OwnerCommented:
Okay - well done.  Good luck.
0
 
meko72Author Commented:
Well I have reapplyed SP2  and within 15 mins. I opened the task manager and CPU was pegged between 93-99 percent with 360k memory. I looked at the event log and saw about 15 3007 errors and one 3014.

In order for me to do anything on server I have to have to either recyle or put the process below normal.
0
 
Alan HardistyCo-OwnerCommented:
Okay - can you reboot the server and when it is rebooting, disable TCP Port 443 Inbound on your firewall, then monitor after 10-15 minutes.
0
 
Alan HardistyCo-OwnerCommented:
Please also ask EVERY iPhone user to tell you their iOS version (Settings> General> About) and if anyone is using iOS v4.0 - ask them to upgrade to a newer version before they try to connect to your server again.
0
 
meko72Author Commented:
I am at a complete lose on this. I think tonight I should try to reset the Default Directories per KB 883380

The only thing that artical doesnt mention is " Exchange-oma"

I have a TZ-210 SonicWall and I am not 100% sure on how to do that on this product


0
 
Alan HardistyCo-OwnerCommented:
Please can you follow my advice.  If it is an iPhone causing the problem - blocking port 443 will stop them from connecting and will help to show that it is more than likely an iPhone causing the problem.

Once the server is up and running with no iPhones connecting - after 10-15 minutes running, if the server is not pegged out processor wise, enable port 443 again and wait.  If it pegs out shortly afterwards - you can look at the iPhones as the cause of the problem.
0
 
meko72Author Commented:
In the Morning I will check all of the I phones and make sure that they are using IOS v4.0.

Do you think that if the clients are using an older software version on thier Iphones it coud cause problems with Activesync on the server like I am having. I assume if this is the solution then those with other activesync devices (Phones) should clear up.

I know this morning One of the EXEC send me an email and it came to me 8 times.. Hmmm
0
 
Alan HardistyCo-OwnerCommented:
They need to be NOT using v4.0 - they need to be anything other than 4.0, preferably 4.1 or 4.2 or even 4.3.

What Anti-Virus software do you have installed and is it configured to ignore the Exchange Structure when scanning?  This could also be causing you problems.
0
 
meko72Author Commented:
Sorry for the typo, anything over 4.0

I had Symantec 10.x on the server and I excluded the exchange structure. Since this Problem is still occuring yestarday I temporally Unistall it.

0
 
Alan HardistyCo-OwnerCommented:
Okay - that was a good move.

I'm about for about 3 hours more tonight so if you are planning on restarting and stopping port 443 - then I am around for you to help if needed.

Alan
0
 
meko72Author Commented:
OK, Good news.. I disabled port 443 and rebooted server and watch it for about 15mins. the CPU usage rarely hit 3 % and then I enabled 443 and within 10 mins CPU is at 99%.
In the morning I am going to upgrade all I phones (7). I will keep ya posted..

Thanks
0
 
Alan HardistyCo-OwnerCommented:
Okay - that's encouraging news.  Good luck upgrading them all!

Alan
0
 
meko72Author Commented:
Well I have some goods and Bad..  Good news all of the Iphones have been upgraded to the latest IOS 4.3.
Now the bad news is that the IIS process is still consuming 92-99 % of the CPU.
Event log still shows 3007 and 3014 errors.

I sent an email one of the I phones early this morning and I have got back 8 times..

0
 
Alan HardistyCo-OwnerCommented:
Hmm - good that they are upgraded but bad the Processor is still pegged.

Can you please check your IIS Settings against my Activesync article in case something isn't set correctly and causing excessive traffic.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 
meko72Author Commented:
I have verified my IIS settings with your article and everything checks out.
0
 
Alan HardistyCo-OwnerCommented:
Good - can you run the Exchange Activesync test on the test site mentioned, specify manual server settings and then post the results if you get any errors.

Thanks
0
 
Alan HardistyCo-OwnerCommented:
Might also be worth downloading the SBS Best Practises Analyzer and see what that highlights as being a problem:

http://www.microsoft.com/downloads/en/details.aspx?familyid=3874527A-DE19-49BB-800F-352F3B6F2922&displaylang=en
0
 
meko72Author Commented:
Here is the Results of the Exchange Activesync test . I have replaced my domain name with "Company"

I am also running a SBS Best Practice Analyzer test, and will update shortly



ExRCA is testing Exchange ActiveSync.
 The Exchange ActiveSync test failed.
 Test Steps
 Attempting to resolve the host name mail.company.com in DNS.
 The host name resolved successfully.
 Additional Details
 IP addresses returned:

Testing TCP port 443 on host mail.company.com to ensure it's listening and open.
 The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
 The certificate passed all validation requirements.
 Test Steps
 Validating the certificate name.
 The certificate name was validated successfully.
 Additional Details
 Host name mail.company.com was found in the Certificate Subject Common name.

Testing the certificate date to confirm the certificate is valid.
 Date validation passed. The certificate hasn't expired.
 Additional Details
 The certificate is valid. NotBefore = 10/27/2006 10:13:48 PM, NotAfter = 10/27/2011 10:13:48 PM



Checking the IIS configuration for client certificate authentication.
 Client certificate authentication wasn't detected.
 Additional Details
 Accept/Require Client Certificates isn't configured.

Testing HTTP Authentication Methods for URL https://mail.COMPANY.com/Microsoft-Server-Activesync/.
 The HTTP authentication methods are correct.
 Additional Details
 ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic

An ActiveSync session is being attempted with the server.
 Errors were encountered while testing the Exchange ActiveSync session.
 Test Steps
 Attempting to send the OPTIONS command to the server.
 The OPTIONS response was successfully received and is valid.
 Additional Details
 Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7653.19
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Thu, 17 Mar 2011 19:28:19 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET



Attempting the FolderSync command on the Exchange ActiveSync session.
 The test of the FolderSync command failed.
 Additional Details
 Exception details:
Message: The operation has timed out
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Tools.ExRca.Tests.ActiveSync.ActiveSyncFolderSyncTest.PerformTestReally()
0
 
Alan HardistyCo-OwnerCommented:
You mention increasing the keep alive value on the default website.  What value did you increase it to?

What firewall / router do you have?
0
 
meko72Author Commented:
The Keep Alive on my default site is set to 480

My Route/firewall   is a Sonic wall TZ 210
0
 
Alan HardistyCo-OwnerCommented:
Are you performing any HTTP / HTTPS inspection on the Sonicwall device?

Is the firmware on the Sonicwall at the latest released version?
0
 
meko72Author Commented:
No we are not doing inspections at all.

My Default TCP connection timeout is 20 mins
Maxium segment lifetime is set to 8 seconds.

Yes we have and are running the lateest firmware,

When I did my SBS analyzer the only thing That came up was that the Microsoft Mobile Access was not using net framework 1.1.4322.
When I changed  it to use the correct framework I noticed that the CPU was down to about 43-5% with  about 124k of memory. That Didnt last long about 20 mins the CPU Pegged out again.

0
 
Alan HardistyCo-OwnerCommented:
Was there an error number for the Activesync test?  I don't see on in the output above?

How much RAM is in your server?
0
 
meko72Author Commented:
No error numbers it stated timed out.
I have 4gig ram
0
 
Alan HardistyCo-OwnerCommented:
Okay - sounds good.

Do you have a temporary replacement firewall that you could swap for the current one for testing to see if the problem is firewall related?
0
 
meko72Author Commented:
Sorry Dont have a Temporary replacement.
Would you think about
1. reset the default virtual Directories Maybe there is some corruptions
2. Creating Secondary V Directory Per KB817379
3 Maybe Break out  the activesync and put it in own application pool. Because with activesync failing so is my Exchange.

0
 
Alan HardistyCo-OwnerCommented:
I agree with the 1st and 2nd options, but would leave the 3rd out of the equation

Zap the Exchange-oma virtual directory when deleting the others and then follow method 2 of KB883380, then follow KB817379 then re-run the connect to the internet wizard and then run iisreset and finally reboot the server.

See how that goes.
0
 
meko72Author Commented:
I found this Link and that is why I thought about putting Activesync its own pool.
http://www.mail-archive.com/exchange@intm-dl.sparklist.com/msg18767.html
0
 
Alan HardistyCo-OwnerCommented:
You would be venturing into unknown territory for me if you do that - so it's your call, but I wouldn't personally.  It's SBS and it's sure to get upset about it.
0
 
meko72Author Commented:
Ok, I will Go with one and Two and Keep you posted.

You know this problem that I am having is really cutting into my fishing time..  LOL
0
 
Alan HardistyCo-OwnerCommented:
Sorry :D

Just think it will give the fish more time to grow extra big, so you might land a big one ;)
0
 
meko72Author Commented:
Well Last night I decided not to reset the directories until this weekend.

I re-ran the connect to the internet wizard afterwards I still noticed that the CPU was still pegged out.
I also went into the properties of the ExchangeApplicationPool and ticked recycle worker process in 120 mins. I also set the memory recycling to 400 megs for Virtual Mem and 256 of used mem.
Since last night the the CPU is running between 3 - 53%.

This morning I check with everyone how had Iphones and Androids and they where up to date with emails.  I ran the ExRCA and it passed.
There was one Gentleman that I took his Iphone and Deleted his exchange off of the phone and re connected him without a hitch.

The only problem that I am currently having is that Internally  I can access OWA but externally I cannot

 Thanks

     Dusty
0
 
meko72Author Commented:
As it turns out OWA worked from the outside but very sluggishly. I am still having the issue despite having to recycle the process worker when It reaches certain memory consumption which is all of the time.
0
 
meko72Author Commented:
I think I found the solution to the problem.

I had a user with an android phone that kept giving him cannot connect to server messages. He also told me that when he looked at his contacts there would be mutiple (15-20) entries for the same name.
I told him that I was going to delete his Corp email off of his phone and that I would add it back when got his contacts straighten out. Two hours later he told me that he was finished and asked if I could add his mail back on. Went fine, just as I thought.

I went to the server to look at W3wp.exe process that was giving me fits and the CPU was way down and the process only consumes 46K of memory. Now mind you that this morning that same Process was consumming over 200k with the CPU at 50-99%.
I also looked in the event viewer and the worker process had not been recycled for over two hours.

0
 
Alan HardistyCo-OwnerCommented:
Did you permit the phone to be configured or did the user configure their own device themselves?

If they did it themselves - it might be prudent to block access unless you allow it as a company and that you configure the device for them, that way if you have any problems, you can see them first hand and deal with it rather than having it bite you on the backside!

Just food for thought.

Alan
0
 
meko72Author Commented:
I configured the phone myself.
0
 
Alan HardistyCo-OwnerCommented:
Okay - so did it configure happily before it went crazy?
0
 
meko72Author Commented:
What do you mean, It got uncrazy after I deleted the user exchange account off of his phone. When the customer cleaned up his contacts and I configured exchange back on his phone the server was fine.

On the server end

              Before the delete  CPU avg 50 - 99% and mem over 200k (Enabled mem Recycling)

             After Delete  CPU Barely Hiting 2% and 46K mem (Disabled Mem Recycling)
              Ran IISRESET and the server has been very very stable for over 24 hours.

The Problem to this whole mess was that one user who problems with his contact in outlook.

0
 
meko72Author Commented:
I am accepting my own solution because I found the solution through research on my own.
0
 
fpstararaCommented:
I am having the same issue.  How do I go about narrowing it down to the device or mailbox?
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 25
  • 23
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now