Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1181
  • Last Modified:

Changing File Sharing Lock Count in Access 2010

I normally use Access 2007 and have run into the File Sharing Lock Count issue and have fixed this using by changing the Registry (HKEY_Local_Machine\SOFTWARE\Microsoft\Office\12.0
Access Connectivity Engine\Engines\Ace\MaxLocksPerFile)

I do not see this sequence when working with Access 2010.
0
jaustinr
Asked:
jaustinr
2 Solutions
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Should be:

HKEY_Local_Machine\SOFTWARE\Microsoft\Office\14.0
Access Connectivity Engine\Engines\Ace\MaxLocksPerFile

JimD.
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
I suggest you use VBA to change this setting on a 'per session' basis only, and not mess with the Registry for this, which my not be possible on some user machines.  

Put this at the beginning of your code for a temporary override of the Default:
DAO.DBEngine.SetOption dbmaxlocksperfile, 25000  ' or higher if necessary

This works very well  ... in any version of Access.

mx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now