• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 417
  • Last Modified:

Red Hat Network issues with Proxy

Hey all.  I have a question.  I recently created a VM with Red Hat client 6.0.  I'm trying to register it on the Red Hat Network but I think our proxy is blocking it from happening.  I have the proxy settings configured under systems and preferences but it doesnt seem to do the trick.  I can browse the internet fine so I know the proxy settings are working.  Any help would be appreciated.  thanks.
0
nyceuser
Asked:
nyceuser
  • 7
  • 5
1 Solution
 
farzanjCommented:
Are you running
rhn_register as root?

What is the error message?
0
 
nyceuserAuthor Commented:
Yes I am.  It tells me that it cannot connect to the red hat network.  it's definitely a proxy issue.  Just not sure how to bypass the proxy.
0
 
savoneCommented:
Type this on the command line

export http_proxy=yourproxyserver:port

Then try again. BTW you have to do this as root.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
savoneCommented:
So let's say your proxy is 192.168.1.2 and its listening on port 8080 you would type in

export http_proxy=192.168.1.2:8080

You can also use the DNS name if it resolves.
0
 
savoneCommented:
The you can register with the following command as root

 rhn_register
0
 
nyceuserAuthor Commented:
Thanks for your help guys.  I'm still having the issue though.  Here is a screen shot.  


Untitled.jpg
0
 
savoneCommented:
type this at the command line to make sure the proxy is set correctly. (as root)


echo $http_proxy
0
 
nyceuserAuthor Commented:
Getting the same thing.  
SNAG-0015.jpg
0
 
savoneCommented:
Your http proxy is not set that's why the command did not return anything.

export http_proxy=http://yourproxyip:port

Then again

echo $http_proxy

If its set the echo command should show you the setting.
0
 
savoneCommented:
here is an example:

$ export http_proxy=http://testproxy.mydomain.com:8080
$ echo $http_proxy
http://testproxy.mydomain.com:8080
$
0
 
nyceuserAuthor Commented:
Still doesn't work :(
SNAG-0016.jpg
0
 
savoneCommented:
Assuming your http_proxy is correct, have you checked your logs for a more informational error message?

I would check the following logs:

/var/log/messages
/var/log/up2date
/var/log/yum.log

0
 
nyceuserAuthor Commented:
Does this help?
SNAG-0017.jpg
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now