Solved

Enable Voice QoS on Cisco ASA 5505

Posted on 2011-03-15
4
2,156 Views
Last Modified: 2012-05-11
Hi everybody-

I'd like some help configuring QoS for voice traffic over our Cisco ASA 5505.

This is our network topography:

(Interweb) <-- Cable Internet --> ASA5505 <--- LAN ---> Polycom VOIP Handset <--- Cable ---> PC

As shown above, our Internet is provided by cable Internet. Our ASA is connected to the LAN over a 10/100 switch. Each Polycom plugs into the switch, and each PC is then plugged into the network port on the back of the Polycom to reduce wiring.

For VOIP, we use a hosted PBX provider named Jive (www.getjive.com). At our office we've found some occasional quality issues. Our Internet bandwidth is 10 Mb/s up and 2 Mb/s (which I verified via Speakeasy's bandwidth tester). I also ran some of the free online VOIP testing tools and the results were "good" quality, per the sites.

Some issues we currently face:

* What appears to be jitter -- voice quality can sometimes be rough
* Occasionally a call will have an echo, at least for me
* 1/100 calls may drop

The first step I'd like to do is to enable QoS on our end. I'll then push the troubleshooting upstream after that. We can't have the ISP enable QoS. We can only enable QoS on our end, but at least that's a start.

I'd like to support up to three calls, which would be 300 Kb/s or so.

Our outside interface is Ethernet 0/0.
Our inside interface is Ethernet 0/1.
Our internal network is 192.168.222.0/24.

We have no QoS configured whatsoever.

I did read the Cisco document on QoS, but I'd really like to have some hand-holding in this specific case.

Thanks!
0
Comment
Question by:puryear-it
  • 3
4 Comments
 

Author Comment

by:puryear-it
ID: 35142243
Our running-config:


Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa-1
domain-name xx
enable password xx encrypted
passwd xx encrypted
names
name xx yy
name xx yy
name xx yy
name xx yy
name xx yy
name xx yy
name xx yy
name xx yy
!
interface Vlan1
 nameif inside
 security-level 100
 ip address ciscoasa-1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address aa.bb.cc.dd 255.255.255.240
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 192.168.222.70
 name-server 192.168.222.61
 domain-name xx
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any time-exceeded
access-list outside_access_in extended permit tcp any host pub-sslvpn.xx eq www
access-list outside_access_in extended permit tcp any host pub-sslvpn.xx eq https
pager lines 24
logging enable
logging timestamp
logging trap informational
logging asdm notifications
logging host inside 192.168.222.61 17/1514
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp pub-sslvpn.xx.com www sslvpn www netmask 255.255.255.255
static (inside,outside) tcp pub-sslvpn.xx.com https sslvpn https netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xx 255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server XX protocol ldap
aaa-server XX (inside) host 192.168.222.70
 ldap-base-dn DC=XX
 ldap-scope subtree
 ldap-naming-attribute sAMAccountName
 ldap-login-password *
 ldap-login-dn CN=CiscoVPNSvc,OU=ServiceAccounts,OU=Users,OU=MyBusiness,DC=XX,DC=local
 server-type microsoft
http server enable
http 192.168.222.0 255.255.255.0 inside
snmp-server host inside 192.168.222.61 poll community public
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec df-bit clear-df inside
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.222.150-192.168.222.200 inside
dhcpd dns sbs 192.168.222.61 interface inside
dhcpd lease 43200 interface inside
dhcpd domain xx interface inside
dhcpd update dns both interface inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:5c3fe9e7f116de742752ebf6d526b857
: end
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 35147455
Here's my take on the situation...
You're going over the Internet though a Cable broadband. There is *no* QoS policy that is going to help the occasional jitter/lost calls/quality issues. All the QoS policy will do on your end is mark the packets as priority as they leave your ASA, only to have that priority tag completely ignored by the rest of the world. QoS is only helpful if you control both ends and all the routers in between maintain and enforce the priority markings within their queuing.
The VoIP QoS policies on ASA were designed to prioritize voice over a site-to-site VPN tunnel where you control both ends. IMHO it won't do you any good in your situation..You'll also have to figure out how the Polycom handset is marking the packets so the ASA can recognize them. dscp ef?
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008080dfa7.shtml

 
0
 

Author Comment

by:puryear-it
ID: 35147634
Maybe I'm asking the wrong question. I want to setup priority queuing in the ASA for my VOIP traffic. I'd like to configure that.
0
 

Author Closing Comment

by:puryear-it
ID: 35207086
He didn't actually answer my question, but gave a decent response.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now