[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Sharepoint 2010 workflow not doing anything

Posted on 2011-03-15
5
Medium Priority
?
331 Views
Last Modified: 2012-08-13
I'm working on a workflow to populate a form based on data from an email. I just ran a test and even though it says completed on the Workflow Status page, there's nothing logged in the history. The first item of the workflow is to log something to the history list, so even if the workflow is failing, I should still see that.

I looked at the files in the workflow folder on my site and I noticed that there is no xoml.rules file unlike all the other workflows I have on my site. Is that the source of my problem?

This particular workflow is a bit of a bear - over 130 variables - so I'm not keen on starting from scratch.

Any ideas?
0
Comment
Question by:steam23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:navdeepmadan
ID: 35144654
please develope a visual studio workflow and add a breakpoint on "onworfkloeactivated event". implemented your functionality
0
 

Author Comment

by:steam23
ID: 35147469
Hi. I confess, I'm not to familiar with visual studio. I'm developing the workflow in Sharepoint Designer 2010.  I don't currently have access to Visual Studio, is it possible to add the breakpoint you mention using SPD?
0
 
LVL 5

Accepted Solution

by:
navdeepmadan earned 2000 total points
ID: 35148668
Please check the ULS logs while execution of the workflow. it will provide you the internal error mesage why it didn't ececuted.
0
 

Assisted Solution

by:steam23
steam23 earned 0 total points
ID: 35165041
I figured it out. Nothing was showing up i the logs, so I recreated the workflow from scratch. Then I noticed another workflow I was working on didn't seem to be updating when I changed it either. After some quick searching i found http://b3no.wordpress.com/2008/09/09/workflow-not-updating-using-sharepoint-designer/ . Apparently, the WebsiteCache for SPD gets corrupted on occasion and needs to be cleared. This manifests as the workflows not updating from the client to the server properly. In my case, the workflow that was was runnig was an earlier version that all I had done so far had been to declare my variables.
0
 

Author Closing Comment

by:steam23
ID: 35196576
You sent me on the right direction. As soon as I saw nothing in the ULS logs, I knew there had to be something else going on.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When using a search centre, I'm going to show you how to configure Sharepoint's search to only return results from the current site collection. Very useful when using Office 365 with multiple site collections.
A while back, I ran into a situation where I was trying to use the calculated columns feature in SharePoint 2013 to do some simple math using values in two lists. Between certain data types not being accessible, and also with trying to make a one to…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question