Solved

fds not starting in centos

Posted on 2011-03-15
4
404 Views
Last Modified: 2012-08-13

Dear Experts:

Have installed centos , fds and samba while running the fds setup following places i have issued the password
1. Info Please enter the administrator ID for the configuration directory
server.  This is the ID typically used to log in to the console.  You
will also be prompted for the password.
[11/03/15:10:53:57] - [Setup] Info Configuration directory server
administrator ID
[11/03/15:10:54:52] - [Setup] Info admin
[11/03/15:10:54:52] - [Setup] Info Password ORANGE
[11/03/15:10:55:48] - [Setup] Info Password confirm ORANGE

2.
[11/03/15:10:57:13] - [Setup] Info Directory Manager DN
[11/03/15:10:57:34] - [Setup] Info cn=Directory Manager
[11/03/15:10:57:34] - [Setup] Info Password  APPLE
[11/03/15:10:58:32] - [Setup] Info Password (confirm) APPLE

installation successful at this time able to login to 389 admin console but while interating the 389 with samba following is the details

3. Create a password for the ldap admin dn (the Directory Manager's Password) in Samba’s secret file:

# smbpasswd -w <ldap-admin-password>  BANANNA

as per the instructions made the same server (as samba sever and ldap server is in the same system) already installed nss_ldap

hence edited the file/etc/ldap.conf and now here there is line bindpw
bindpw < > please tell me what password should i give as while above installation given ( ORANGE, APPLE and BANANNA)
please suggest me which is the password i have to enter in the bindpw
bindpw <  >
when try to execute
net getlocalsid
[2011/03/16 02:47:46, 0] lib/smbldap.c:smbldap_connect_system(982)
  failed to bind to server ldap://globalvalue.com with dn="cn=Directory Manager" Error: Can't contact LDAP server
        (unknown)
[2011/03/16 02:48:01, 0] utils/net.c:net_getlocalsid(651)

also fds service not starting error failed to bind to server

Please help me to fix this. Thanks in advance.
0
Comment
Question by:D_wathi
  • 2
  • 2
4 Comments
 
LVL 12

Accepted Solution

by:
upanwar earned 500 total points
ID: 35144467
for bind password it shoul be APPLE.

Have you configured your DNS properly? Which version of fds you are using?
0
 

Author Comment

by:D_wathi
ID: 35148052
Sir, thank you very much for the reply. i reinstalled the centos and managed to fix  DNS issues now the resolve is happening perfectly and fds service starts and stops without any problems. after editing the /etc/ldap.conf and adding the also added values to the smb.conf when execute  # net getlocalsid error is lib/smbldap.c.smbldap_connect_system failed to bind to server ldap://orange.scom with dn="Cn=Directory Manager Error Cant contact LDAP server. please please help
0
 
LVL 12

Expert Comment

by:upanwar
ID: 35148859
Is your server accesable with admin console and web interface? If yes then are you accessing that with Cn=Directory Manager or something else.

Bind your LDAP server with IP instead of HOSTNAME and test if it works.
0
 

Author Comment

by:D_wathi
ID: 35149322
Sir, Iam very happy now finally fixed after 48 hours and it is because of your valuable support. Thank you sir , i had done a mistake of setting different password for ldapadmin manager and the smbpasswd -w after seeting the smbpasswd-w password to the same as ldapadmin manager password then able execute the net getlocalsid :
net getlocalsid
SID for domain SERVER is: S-1-5-21-4226951453-1010018445-1630448079

sir finally one help that is before fixing this error i had populated wrong value of SID for domain only now i got the correct SID .

wrong one sambaSID: S-1-5-21-2310632473-2390155749-10759181
Correct one :SID for domain SERVER is: S-1-5-21-4226951453-1010018445-1630448079

since i have already populated the wrong one please tell me how to delete the wrong entry and replace with new correct entry please please help,
for your reference posted below the wrong ldif populated entry:
 cat sambaDomainName.ldif
dn: sambaDomainName=orange,dc=orangecity,dc=com
objectClass: sambaDomain
objectClass: sambaUnixIdPool
objectClass: top
sambaDomainName: orange
sambaSID: S-1-5-21-2310632473-2390155749-10759181
uidNumber:550
gidNumber:550
------------------------------------------------------------------------
Please please help.






0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now