Solved

error occurred loading a configuration file - in VS 2008 on one computer but not on another

Posted on 2011-03-15
19
600 Views
Last Modified: 2012-05-11
I developed a web application in VS 2008 using one PC and I don't get any errors.
I opend the web app on another PC with VS 2008, first directly from the UNC path, \\server\E$\Inetpub\Website, then but opening a copy of the Solution created on the other pc.  In both cases I get the error below:  (Blue squiggly line under top line)

I closed and reopened the site and still get the error.  1st PC is Windows XP, 2nd PC is Windows 7.

We have recently moved all our web apps from a Windows 2003 (IIS6) server to a new Windows 2008R2 (IIS7.5) server, but the site has been working fine and opening fine on the 1st PC.  I've had to try to work on it with the 2nd PC because the first one keeps crashing (unrelated problem).

This line of the error is strange because it shows the path to the web.config file as if the web page was a folder.  Is that normal?
\\IntraServ\e$\inetpub\QATools\wp_jobseeker.aspx\web.config

{oh, please don't just show me a link to support.microsoft.com/kb/31####.  I already read it. It didn't help. Thanks.}
<%@ Register assembly="AjaxControlToolkit" namespace="AjaxControlToolkit" tagprefix="cc1" %>
Warning 1 \\IntraServ\e$\inetpub\QATools\WP_JobSeeker.aspx: 
ASP.NET runtime error: An error occurred loading a configuration file:
 Failed to start monitoring changes to 
'\\IntraServ\e$\inetpub\QATools\wp_jobseeker.aspx' 
because access is denied.
 (\\IntraServ\e$\inetpub\QATools\wp_jobseeker.aspx\web.config)
	File:\\IntraServ\e$\inetpub\QATools\WP_JobSeeker.aspx	
Line:1	Line:1	Project:\\IntraServ\e$\inetpub\QATools\

Open in new window

0
Comment
Question by:megnin
  • 13
  • 6
19 Comments
 
LVL 16

Expert Comment

by:Kamal Khaleefa
ID: 35146587
are u using ajax?

when u move to the new server you have to install ajax there
also make sure all the dll are imported correctly and exist in ur system
0
 
LVL 1

Author Comment

by:megnin
ID: 35146798
Yes, I'm using AJAX in most of my web applications, a dozen or so.  I moved them to the new server a few weeks ago and everything works fine when I edit them in VS2008 on the 1st PC.  

Are you saying I need to reinstall AJAX on the server because I'm loading the web app on a different PC?
0
 
LVL 16

Accepted Solution

by:
Kamal Khaleefa earned 500 total points
ID: 35146820
i think so
or make sure the ajax dll are referenced in ur project
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 1

Author Comment

by:megnin
ID: 35146887
Oh, I probably need to install AJAX in VS on the new PC.  I just installed VS yesterday and haven't added anything to it.  I'll go do that right now...
0
 
LVL 1

Author Comment

by:megnin
ID: 35148724
Okay, I installed AJAX Toolkit 40412 for 3.5 on the new VS install.  No change.  I still get the same error on the new PC.
0
 
LVL 16

Expert Comment

by:Kamal Khaleefa
ID: 35148751
mmmm..?
try to exclude and then include ur dll files and compile ur project and then build it
try to show me the full error
0
 
LVL 16

Expert Comment

by:Kamal Khaleefa
ID: 35148759
show me screen shot if possible
0
 
LVL 1

Author Comment

by:megnin
ID: 35149020
>>>Sorry, I just got out of a meeting<<<
I opened an extremely simple web app project and just loaded an .html file into VS.  This .html file has, like a pair of <div> tags with "TEST" between then.  When I tried to run debug it I got this:

------ Build started: Project: \\intraserv\e$\inetpub\WIACaseLoad\, Configuration: Debug Any CPU ------
Validating Web Site
: Build (web): Failed to start monitoring changes to '\\intraserv\e$\inetpub\WIACaseLoad\global.asax' because access is denied.

Seems to be related.
0
 
LVL 16

Expert Comment

by:Kamal Khaleefa
ID: 35149073
because access is denied. ??
maybe it is domain security problem
why u don't copy the full project and put it on ur machine and run it from there it is much better than through the network
also on ur folder which contain the project do the following
right click ---properties---security---add the network service to ur folder
and give it full permission
0
 
LVL 1

Author Comment

by:megnin
ID: 35149107
On my local machine, like, C:\My Documents\Visual Studio 2008\Projects\Website1 ?
0
 
LVL 1

Author Comment

by:megnin
ID: 35149179
I added Network Service to my projects folder with full control.

I looked at the security settings for \\Server\E$\Inetpub and Network Service had only "list folder contents" and "Read" checked.  I change it to full control... it's still going through the files...
0
 
LVL 16

Expert Comment

by:Kamal Khaleefa
ID: 35149197
i hope it will work
0
 
LVL 1

Author Comment

by:megnin
ID: 35149205
me too.  ;-)
0
 
LVL 1

Author Comment

by:megnin
ID: 35149274
It's still setting security settings on every file in Inetpub.  I hope I didn't just goof.  8-O
0
 
LVL 1

Author Comment

by:megnin
ID: 35149306
...our Intranet is a document management system so there are 10 to the 12th files in there.
0
 
LVL 1

Author Comment

by:megnin
ID: 35149442
Same error.

I tried excluding then including the AjaxControlToolkit.dll then rebuilding the project but it wouldn't build and I got this error in addition to the same one above.

Error      28      Failed to start monitoring changes to '\\IntraServ\e$\inetpub\QATools\global.asax' because access is denied.            

It's obviously a permissions thing but I don't know what to change.
0
 
LVL 1

Author Comment

by:megnin
ID: 35149455
I don't see a global.asax file in the folder specified in the error.
0
 
LVL 1

Author Comment

by:megnin
ID: 35149463
I do have show all files selected in the Solution Explorer.
0
 
LVL 1

Author Comment

by:megnin
ID: 35233953
I just discovered, after much Googling around and checking permissions and permission inheritance in IIS and on all the folders from Inetpub down, that if I run Visual Studio "As Administrator" the error goes away.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
FTP Directory Permissions 3 37
How do I write a redirect rule for this scenario? 2 32
Footer for each row on Gridview 2 33
Convert Select to DropDownListFor MVC 5 2 30
Introduction This article shows how to use the open source plupload control to upload multiple images. The images are resized on the client side before uploading and the upload is done in chunks. Background I had to provide a way for user…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
THe viewer will learn how to use NetBeans IDE 8.0 for Windows to perform CRUD operations on a MySql database.

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question