Solved

USB Ports not working

Posted on 2011-03-15
7
436 Views
Last Modified: 2012-08-13
HP Pavilion a465c Desktop computer with a P4SD-LA motherboard won't read USB devices or media cards. This is the case with the ports on the front and in the back of the system. The usb devices get power, that is, the light in the mouse or flash drive comes on but the device is not recognized. I have performed a repair install of Windows XP, have run virus scans, malwarebyte, combofix, taken the RAM out one stick at a time and tried several different usb devices with no luck. I updated the BIOS, checked to see if the ports were disabled and even uninstalled and reinstalled all usb drivers. I am at my wits end. Please advise.

Thank you!
Robert
0
Comment
Question by:RobertEhinger
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 5

Expert Comment

by:KPAYNE123
ID: 35142858
It sounds like you have already invested a bunch of time and you really need to find out if this is windows or the computer. Download this: http://puppylinux.org/main/Download%20Latest%20Release.htm which is an ISO file that you can burn to a CD - Boot from the CD and you will find a cool app called Puppy Linux and try your USB devices there. This should not take more than 15 minutes and you will know if this is Windows (most likely) or an actual computer issue.
0
 
LVL 20

Expert Comment

by:CompProbSolv
ID: 35142901
Following on KPAYNE's suggestion, if the USB devices do NOT work with Puppy Linux, you know there is a hardware issue.  If they DO work, Windows is suspect.

In the latter case, try the same test with Bart PE from http://www.nu2.nu/pebuilder/
It is a very handy tool (bootable Windows XP on a CD) to have in any case.  If the USB devices work there, you know it has to do with the particular installation of Windows that you have, not Windows in general.
0
 
LVL 1

Expert Comment

by:hayrikarakuzu
ID: 35143125
KPAYNE123: and CompProbSolv: have said my first advices i was thinking. Additionally you can try USB 1.0 devices.  It looks like USB 2.0 device driver support problem.  This problem is not common in these days. was several years ago.   Try my advice if you having this problem despite you try first two advices without no solition. good luck.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:RobertEhinger
ID: 35147337
I tried the suggestions above and no USB devices were found.
0
 
LVL 20

Expert Comment

by:CompProbSolv
ID: 35150788
If neither Linux nor Windows (two installations, HD and Bart) do not recognize any USB devices, I'd suggest it is one of the following (no particular order):

1) USB ports disabled in the BIOS (you stated you checked that, so not likely)
2) defective USB hardware in the computer (most likely)
3) odd USB hardware that doesn't have drivers included with either OS and what you updated to is incorrect (unlikely)

The fact that the rear ports have the problem eliminates cabling as an issue.  (I'm assuming that the ports are directly connected to the motherboard, not through a cable.)

I should have mentioned that with Bart PE the USB device must be connected before you boot.  That's one of the many limitations of Bart.

I would consider replacing the motherboard (expensive) or just working around it by installing a PCI USB card.  They can be had for $10-20.  I've had trouble with some of those, though.  If I recall correctly, the NEC chip ones are pretty good where the Via (or is it Realtek) have problems.
0
 
LVL 5

Expert Comment

by:KPAYNE123
ID: 35151034
The advise that CompProbSolv gives you last is best. The Hardware is the problem. Make sure that you have an available slot and buy a USB card to fit that slot. The USB Controller chip on the Motherboard must be the issue. The ports will still provide power, but will not comunicate with software.
0
 
LVL 1

Accepted Solution

by:
hayrikarakuzu earned 500 total points
ID: 35151869
If you have not got any solution yet, even though you reset bios.

Please try to recognize any USB device without  OS(booting from Acronis, ERD Commander or Linux or any other boot media disc. )

If you can not explore USB : means hardware %100 mulfnctioned. throw it away.
in case of USB exploring: USB ports are alive but has some problem. This problem can be hardware or sofware problem.  If it is software problem it is likely easy to solve.

if it is hardware problem, best thing is leaving this hardware.

I had  similar problem like that  10 monthes ago. I had caused a short circuit on the mainboard. So a lightening has been viewed.    The motherboard was not recognizing the PCI devices and SATA HDD prots.  So i migrated the system onto parallel disc. I had used Acronis Boot media to recover my data on the SATA disc.  Then i got my board tested, they said me my southern bridges has been damaged.  There was no except changing CMOS on the board. it is several times expensive form a new board and the solution is not quarantied.  

Even you will have change the chip of  board, it is not quarantied to work with all standart hardware.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

This is an article based on some fact, and much personal opinion. While you may differ from me in the things you value in a personal computer, I hope this advice can serve to inspire a more objective comparison of two computers, help your figure out…
This article is a cursory discussion of Intel SpeedStep Technology (SpeedStep) and Enhanced Intel SpeedStep Technology (EIST).  The goal is more to illuminate what these technologies are and are not.  The detail of how each technology works is not a…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now