Solved

DVD-RW: Incorrect Function error

Posted on 2011-03-15
10
588 Views
Last Modified: 2012-05-11
Hello!

I am having trouble with a computer that will not access the DVD-RW if any blank media is inserted. When I click it, I get the error "Unable to access E:\ Incorrect Function" Normal DVDs and CDs that have been burned and had their tracks closed open fine.

To troubleshoot this problem, I have done the following:

1. Uninstalled Roxio DirectCD 5 and DirectCD 6
2. Run RoxiZap to remove remaining Roxio files
3. Uninstalled the DVD drive from Device Manager
4. Set the drive from DMA mode to PIO mode
5. Run the XP CD/DVD fix program often listed in these kinds of threads
6. Deleted Upper Filters/Lower Filters
7. Installed Nero BurnLite to see if I could trick it into working again
8. Performed an SFC /scannow to check system files
9. Disabled anti-virus, uninstalled anti-virus, etc
10. Checked for a "Burning" tab after selecting the drive in My Computer and choosing "Properties", there is no Burning tab.
11. I installed Adaptec ASPI drivers to see if there would be any effect.

I tried to run the Microsoft FixIt Tool for CD/DVD drives, but it will not run and gives an error, saying the tool is not necessary for the system or some other garbage.

I am running out of troubleshooting steps. Anyone have any potential solutions?
0
Comment
Question by:techasker
10 Comments
 
LVL 16

Assisted Solution

by:sjklein42
sjklein42 earned 100 total points
ID: 35143587
Here's the Microsoft article about this:

http://support.microsoft.com/kb/316529/

When you view the properties of the CD-R drive or the CD-RW drive, you notice that the Recording tab is not displayed in the CD Drive (drive_letter:) Properties dialog box, where drive_letter is the letter of the CD-R drive or CD-RW drive.
0
 
LVL 3

Assisted Solution

by:shjacks55
shjacks55 earned 400 total points
ID: 35143808
   Might provide more detail: like when this stopped working, did it ever work....
Of course you don't mention what kind of computer and what kind of DVD-R/W this is were just guessing. If this is a new DVD-R/W, maybe it is just DOA?
    Since Windows Explorer only recognizes formatted disks and the media is blank, we expect this error. If this is direct connected then we get the BIOS information from the DVD-R/W and the type name is compared to the .INF file of your burning program (ASPI provider). Adaptec provisioned the original Microsoft burning capability as part of MediaPlayer, like 10 years ago.
    Newer devices can tell the burning software how to burn them, not a default in ancient XP. I'm guessing that you have a five year old computer design with SATA, BIOSes often had buggy support for ATAPI over SATA, your DVD or CD is recognized but advanced commands are not transmitted. Because XP did not recognize true SATA,  XP is installed with BIOS set for "IDE emulation mode". Your previous CD was probably operating in this IDE mode. The new DVD-R/W was autodetected as "true SATA".
    Again, we don't know the details of your system. The DVD-R/W could be Firewire or USB 2.0


0
 

Author Comment

by:techasker
ID: 35150039
Okay, here are some followup details.

It is unknown when the DVD burner started having this issue. This issue happens when ANY DVD burner is connected to the system, SATA or IDE. The current burner is IDE.

I attempted the registry fix sjklein42 suggested and it did not work unfortunately. One thing to note here is that when I put in a either a blank DVD or blank CD, the "DVD-RW Drive" naming for drive E: changes to "CD Drive".
0
 
LVL 3

Assisted Solution

by:shjacks55
shjacks55 earned 400 total points
ID: 35169931
1. http://support.microsoft.com/kb/982116 has some device manager codes. The problem sounds like the hotfix for Vista, but this XP right?
2. Adaptec ASPI: Roxio was the name given to Adaptec's CD Burning software after spun off from Adaptec. Would explain why DVD changed to CD if it was the late 80's software.
3.  Trying to pin down when this happened: I'm a firm believer in using system restore, pick a few days before. You uninstalled all burning software (  http://support.microsoft.com/kb/315350 )(which would cause this) and ran a cleaner program, but then that would have had changed reg keys as well.
4. If you have access to another burner you might burn then run antivirus rescue CD: F-secure, Avast, AVG, et al. viruses can interfere with drivers.  Viruses can interfere with disk drivers.
0
New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

 

Author Comment

by:techasker
ID: 35192555
This is Windows XP. I've went through the motions with drivers and whatnot. I ended up installing the Nero Multimedia Suite trial, which allowed me to see the following symptoms:

The drive can read from completed discs with their tracks closed, but if the disc is an RW with it's tracks open, the disc will not be read. I can use the Nero disc recovery program to pull the files off of any CDs or DVDs I have left that aren't completed but have files on them.

The device manager does not have any errors or codes for the DVD drive at all, it is installed normally.

I have checked with approximately 7-8 different anti-virus programs, they all give the system a clean bill of health.

From what I can tell, Roxio permanently damaged the system's built-in burning software and it will now need software like Nero to interact with burnable discs.
0
 
LVL 1

Expert Comment

by:WBGames
ID: 35207410
Just delete the CDROM drive from device manager and retsart windows and let it detect it again.

See if that helps
0
 

Author Comment

by:techasker
ID: 35219007
Thanks for the reply WBGames, but I tried that pretty early one and later as well, it's #3 in the original post

(3. Uninstalled the DVD drive from Device Manager)
0
 
LVL 3

Accepted Solution

by:
shjacks55 earned 400 total points
ID: 35224907

You state:
"I am having trouble with a computer that will not access the DVD-RW if any blank media is inserted. When I click it, I get the error "Unable to access E:\ Incorrect Function" Normal DVDs and CDs that have been burned and had their tracks closed open fine."
Did the Computer ever burn to the DVD-RW? What was the last things the user did to make it stop working? Did you try a "system restore" to the day before? Does the blank media spin up when inserted? Low speed or high speed?

Blank media should not be blank. The first 15 tracks contain information about the CD (or DVD equivalent) including write strategy.  This is how your motherboard BIOS sees the ATAPI device information in CMOS Setup and passes to OS. Perhaps BIOS settings changed. DVD-RW (unknown model) may not be compatible with the (unknown) disk media. Copy Linux (Knoppix) live distribution to USB Drive and see if that Burner Software works. Alternative is parallel install of XP.

Your antivirus may be ineffective if the system has a rootkit; that is why you would boot from A-V recovery CD or Floppy. Your system may have a rootkit installed, Sony installed one from their Music CDs. It boots before your antivirus which prevents your A-V from detecting it.
Removal from device manager leaves "ghosts" in the Enum keys ( HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\IDE\CdRomSONY_DVD_RW ). Removal in safe mode with show all devices probably more reliable.

0
 

Author Closing Comment

by:techasker
ID: 35428531
unfortunately none of the excellent recommendations posted here solved this issue. I will no longer be able to test any further recommendations, so I will be closing this question.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
This is about my first experience with programming Arduino.
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now