Solved

DNS forwarding to 1 IP address with multiple domains

Posted on 2011-03-15
15
1,330 Views
Last Modified: 2012-05-11
I have an IIS Server with a dedicated IP address. The server currently hosts 1 website on that IP (abc.com)

I have a request to get a 2nd domain (xyz.com) pointing to a different application on that server on port 90.

So basically, instead of them having to enter an IP address in the URL bar of their browser, I want them to be able to use the domain name.

I have control of the DNS.

I don't have a clear idea of what all the steps are required to complete this.

 - update DNS to point the domain to the IP address of the server
   - should the DNS forwarding be with or with out the port :90 included?

- add the site in IIS (xyz.com) to be bound to port 90 on the IP address of the server

Is that correct? Is there anything missing?

Thanks
IT_Service
0
Comment
Question by:IT_Service
  • 8
  • 6
15 Comments
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 35144700
update DNS to point the domain to the IP address of the server.

and in IIS create hostheaders for example.
192.168.0.100   90        www.xyz.com
192.168.0.100   90        xyz.com
0
 
LVL 9

Expert Comment

by:tanujchandna
ID: 35146993
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35148752
Ok, now in the DNS I have www.xyz.com and xyz.com pointing to the Public IP of the webserver.

In IIS, I set up the site bindings for

xyz.com : 90
www.xyz.com : 90

Yet, when I use the URL http://111.111.111.111:90/SearchPortal.aspx?id=OatHbSCh/y8=

(where 111.111.111.111 is the public IP) it works fine.


But if I try to replace the IP with http://www.xyz.com:90/SearchPortal.aspx?id=OatHbSCh/y8=

I get this error in my browser:

*********************
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

*********************

0
 
LVL 9

Accepted Solution

by:
tanujchandna earned 500 total points
ID: 35148803
Hi,

Only use the following code in web.config file and it will show you the exact error:

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>

Delete everything except the above in web.config (Please do the backup of web.config file when doing this)
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35176273
Here is the error that is now returned. I don't know what to make of it, but have passed it off to the developers. Any ideas?

Thanks.

***********

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'NRwebSearch' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

Source Error:

Line 57:                 <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 58:                 <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 59:                 <add assembly="*"/>
Line 60:                 <add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>
Line 61:                 <add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>


Source File: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config    Line: 59

Assembly Load Trace: The following information can be helpful to determine why the assembly 'NRwebSearch' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
0
 
LVL 9

Expert Comment

by:tanujchandna
ID: 35179417
Hi,

Now add these assemblies in your web.config file which you recently created. Add all the remaining lines also which you will find in error after adding these lines.

Note: Do not add any other line which is not required by your web.config in error.
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35212109
I'm not familiar with the web.config file structure... Would the following be correct?
*****************

<?xml version="1.0"?>
<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>

<add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
<add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
<add assembly="*"/>
<add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>
<add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>

</configuration>

************************

Or do the added assemblies need to be contained in some kind of <section> </section>?

thanks
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 9

Expert Comment

by:tanujchandna
ID: 35212518
Hi,

Provide me your complete web.config file, I will modified it and get back to you.
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35212641
You want the original file ... the one I made a backup of before changing it to what is posted above?
0
 
LVL 9

Expert Comment

by:tanujchandna
ID: 35213823
Hi,

Your original backup file.
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35220557
Here is the complete text ... with of course public key tokens, user names and passwords replaced:
***************************************************
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="devExpress">
      <section name="settings" type="DevExpress.Web.ASPxClasses.SettingsConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="compression" type="DevExpress.Web.ASPxClasses.CompressionConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="themes" type="DevExpress.Web.ASPxClasses.ThemesConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="errors" type="DevExpress.Web.ASPxClasses.ErrorsConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <!--<section name="compression" type="DevExpress.Web.ASPxClasses.CompressionConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />-->
      <!--<section name="themes" type="DevExpress.Web.ASPxClasses.ThemesConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />-->
      <!--<section name="errors" type="DevExpress.Web.ASPxClasses.ErrorsConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />-->
    </sectionGroup>
  </configSections>
  <appSettings />
  <connectionStrings>
    <add name="Search_Con" connectionString="server=.;database=@databasename;Integrated security=false;User Id=User1;password=passwordone;" />
   
  </connectionStrings>
  <system.web>
    <!--
            Set compilation debug="true" to insert debugging
            symbols into the compiled page. Because this
            affects performance, set this value to true only
            during development.
        -->
    <compilation debug="true" targetFramework="4.0">
      <assemblies>
        <add assembly="DevExpress.Web.ASPxEditors.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Data.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxGridView.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxHtmlEditor.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxSpellChecker.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <!--<add assembly="DevExpress.XtraSpellChecker.v10.2.Core, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />-->
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=edcba0987654321" />
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=fedcba0987654321" />
        <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=abcdef1234567890" />
        <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=abcdef1234567890" />
      </assemblies>
    </compilation>
    <!--
            The <authentication> section enables configuration
            of the security authentication mode used by
            ASP.NET to identify an incoming user.
        -->
    <authentication mode="Windows" />
    <!--
            The <customErrors> section enables configuration
            of what to do if/when an unhandled error occurs
            during the execution of a request. Specifically,
            it enables developers to configure html error pages
            to be displayed in place of a error stack trace.

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
    <httpModules>
     <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" name="ASPxHttpHandlerModule" />
    </httpModules>
    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID" />
  </system.web>
  <!--
        The system.webServer section is required for running ASP.NET AJAX under Internet
        Information Services 7.0.  It is not necessary for previous version of IIS.
    -->
  <system.webServer>
    <modules>
      <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" name="ASPxHttpHandlerModule" />
    </modules>
    <validation validateIntegratedModeConfiguration="false" />
  </system.webServer>
  <devExpress>
    <compression enableHtmlCompression="false" enableCallbackCompression="true" enableResourceCompression="true" enableResourceMerging="false" />
    <themes enableThemesAssembly="true" />
    <errors callbackErrorRedirectUrl="" />
    <settings rightToLeft="false" />
  </devExpress>
</configuration>
***************************************************
0
 
LVL 9

Expert Comment

by:tanujchandna
ID: 35220788
Hi,

Try with following web.config code

<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="devExpress">
      <section name="settings" type="DevExpress.Web.ASPxClasses.SettingsConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="compression" type="DevExpress.Web.ASPxClasses.CompressionConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="themes" type="DevExpress.Web.ASPxClasses.ThemesConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
      <section name="errors" type="DevExpress.Web.ASPxClasses.ErrorsConfigurationSection, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" requirePermission="false" />
        </sectionGroup>
  </configSections>
  <appSettings />
  <connectionStrings>
    <add name="Search_Con" connectionString="server=.;database=@databasename;Integrated security=false;User Id=User1;password=passwordone;" />
   
  </connectionStrings>
  <system.web>
        <compilation debug="false" targetFramework="4.0">
      <assemblies>
        <add assembly="DevExpress.Web.ASPxEditors.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Data.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxGridView.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxHtmlEditor.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="DevExpress.Web.ASPxSpellChecker.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" />
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=edcba0987654321" />
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=fedcba0987654321" />
        <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=abcdef1234567890" />
        <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=abcdef1234567890" />
      </assemblies>
    </compilation>
   
        <customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
     
  <system.webServer>
    <modules>
      <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v10.2, Version=10.2.4.0, Culture=neutral, PublicKeyToken=1234567890abcdef" name="ASPxHttpHandlerModule" />
    </modules>
      </system.webServer>
  <devExpress>
    <compression enableHtmlCompression="false" enableCallbackCompression="true" enableResourceCompression="true" enableResourceMerging="false" />
    <themes enableThemesAssembly="true" />
    <errors callbackErrorRedirectUrl="" />
    <settings rightToLeft="false" />
  </devExpress>
</configuration>
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35222232
Ok, now I just get this error:

Server Error
500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.
0
 
LVL 2

Author Comment

by:IT_Service
ID: 35311607
The developers somehow resolved the issue.

Thanks for you help.
0
 
LVL 2

Author Closing Comment

by:IT_Service
ID: 35311611
solutions was arrived at with help of others as well as this.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

One of the most often confused topics in the area DNS is the idea of GLUE records. Specifically, what they are, when they are needed, when they are provided, and how they are created. First, WHAT IS GLUE? To understand GLUE, you must first under…
There have been a lot of times when we have seen the need to enter a large number of DNS entries in a forward lookup zone. The standard procedure would be to launch the DNS Manager console, create the Zone and start adding new hosts using the New…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now