?
Solved

Change Server Collation in SQL 2008 after installation

Posted on 2011-03-15
9
Medium Priority
?
824 Views
Last Modified: 2012-06-21
Hello experts,

I need to change server collation in SQL 2008 from Latin1_General_CI_AS to SQL_Latin1_General_CP1_CI_AS. Is this possible?

Please advise.

Thanks and Regards
0
Comment
Question by:goprasad
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 75

Expert Comment

by:Aneesh Retnakaran
ID: 35144263
you need to rebuild  the master database
0
 
LVL 75

Accepted Solution

by:
Aneesh Retnakaran earned 1500 total points
ID: 35144295
0
 

Author Comment

by:goprasad
ID: 35144348
After dropping user databases, I need to run the following command, be selecting new query. Is the following fill up the blanks correct?

Setup /QUIET /ACTION=REBUILDMASTER /INSTANCENAME=<my instance name>
/SQLSYSADMINACCOUNTS=sa /[ SAPWD= StrongPassword ]
/SQLCOLLATION=SQL_Latin1_General_CP1_CI_AS
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 75

Expert Comment

by:Aneesh Retnakaran
ID: 35144356
you dont need to drop the user dbs.
seems to be correct
0
 

Author Comment

by:goprasad
ID: 35144418
When I run the query I am getting the msg: Incorrect syntax near '/'
0
 
LVL 79

Expert Comment

by:arnold
ID: 35144568
As referenced in the link posted by aneeshattingal, can you use a per database collation settings as referenced in the Note:?

Note

Instead of changing the default collation of an instance of SQL Server, you can specify a default collation for each new database you create.
0
 
LVL 30

Expert Comment

by:Olaf Doschke
ID: 35145016
Try this as a one line command, remove the line breaks to get rid of the syntax error.

Bye, Olaf.
0
 

Author Comment

by:goprasad
ID: 35186900
I took the easy way out, re-installed the named instance with correct collation.
0
 

Author Closing Comment

by:goprasad
ID: 35186914
I had to re-install the SQL Named instance selecting the correct collation.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article I will describe the Detach & Attach method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
In this article we will get to know that how can we recover deleted data if it happens accidently. We really can recover deleted rows if we know the time when data is deleted by using the transaction log.
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question