Solved

SBS 2003 Mail stuck in local delivery queue in Exchange

Posted on 2011-03-16
18
1,309 Views
Last Modified: 2012-08-14
Hi All,

The issue we are experiencing is that various mails are stuck in the local delivery queue of our Exchange 2003. Some emails seem to be flowing through but a large majority are stuck retying and never go through.

The emails are from various domains.

I have run:
isinteg -s SBS -fix -test alltests (No errors)
eseutil /p (No issues)

There are no errors logged in the event viewer either.

Server is running Symantec Endpoint Protection - I've seen various posts where people suggest uninstalling this but all result in no change of status with regards to the mail. (I have not yet tried this)

Does anyone have any suggestions?

Kind regards
Dane



0
Comment
Question by:gerard_thusa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 2
  • +2
18 Comments
 
LVL 7

Expert Comment

by:waleeda
ID: 35146322
if you double click on the queue, it will show all the messages, then scroll to right side to see the reason of queuing the messages, can you write me the reason please?
0
 

Author Comment

by:gerard_thusa
ID: 35146383
When i double click i get the window 'Find messages - Local Delivery'

The details given here are:
Sender
State
Message Size
Time Submitted
Time Received by server
Time Expires
Subject

I cannot seem to find any place where it notifies me of a reason for failing.
0
 
LVL 7

Expert Comment

by:waleeda
ID: 35146397
after the subject there is no any field called last error?
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 17

Expert Comment

by:Sikhumbuzo Ntsada
ID: 35146514
Chceck if you can ping to the internet maybe some one changed your DNS settings
0
 
LVL 7

Expert Comment

by:waleeda
ID: 35146519
which emails queued, internal emails or external emails?
0
 

Author Comment

by:gerard_thusa
ID: 35146633
DNS Setttings are all correct. Confirmed this.

Mail received from internal and external users bound for the internal domain are being held in the queue.
0
 
LVL 7

Expert Comment

by:waleeda
ID: 35146668
can you please explain more
please answer my below questions:
1- are you able to send internally?
2- are you able to receive internally?
3- are you able to send to external users?
4- are you able to receive from external users?
0
 

Author Comment

by:gerard_thusa
ID: 35146693
This is the frustrating thing is that there seems to be no pattern.

1.) internal mails - some are going through, others held in the queue.
2.) receive internally - again, some mail is received, other mail is held in the queue
3.) mail is sending externally without any issues (none that I'm aware of)
4.) I have send mail externally and replied to this. The mail did the trip without any delay.
0
 
LVL 8

Expert Comment

by:GundogTrainer
ID: 35146729
You could try running the MTAcheck utility to see if there is a bad message that is hanging some of the worker threads, also are there any restrictions of people or groups that are denied permissions to send through the connector ? as I have seen this cause issues before.
0
 

Author Comment

by:gerard_thusa
ID: 35146758
There are no special permissions setup on the server restricting sending or receiving.

How do I run the MTACheck ?
0
 
LVL 7

Expert Comment

by:waleeda
ID: 35146762
do you have Forefront or Antigen Applications?
0
 

Author Comment

by:gerard_thusa
ID: 35146808
Symantec Endpoint.

No Forefront or Antigen.
0
 
LVL 8

Expert Comment

by:GundogTrainer
ID: 35146830
Sorry I forgot to post the links:

XCON: Performing An MTACHECK
http://support.microsoft.com/kb/175495

I cantr remember if it is included by default but if not:
To run the Mtacheck.exe utility on Exchange Server 2003, first download the utility. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=42bb1866-76ec-4a2a-bb80-ec247534d1fd&displaylang=en
0
 

Author Comment

by:gerard_thusa
ID: 35147586
Apologies for the delay.
____
C:\Program Files\Exchsrvr\bin>MtaCheck

Starting object integrity checks

Database clean, no errors detected.
0
 
LVL 2

Expert Comment

by:Darran Brown
ID: 35148088
Hi
I'm not an exchange bod as such but spotted your question while I happened to be with our  exchange guy who kindly wrote the following.  Hope it helps.

Increase logging for  the following in ESM

MSExchangeIS->Mailbox
  Transport general
  transport sending

MSExchangeMTA
  Directory Access
  Internal Processing

MSExchangeTransport
  Routing engine/service
  categorizer
  Queuing engine
  SMTP protocol

Look for categorizer errors in event log this should indicate the issue, if not the other logging will point you in the right direction. To help

on the hdd locate the \mailroot\vsi 1\queue folder

in here is where the stuck messages will be. you can move them out to another folder and then copy them back in one by one checking the event log to see what is logged

You may need to stop the services to allow you to move the messages out of this folder

check your smtp server is not failing and restarting (unlikely)

make sure your AV is not scanning the exchange folders
0
 
LVL 7

Expert Comment

by:waleeda
ID: 35151350
try to stop your antivirus and check
0
 

Accepted Solution

by:
gerard_thusa earned 0 total points
ID: 35186732
Hi All,

Apologies for the lack of update on this.

All suggestions were tried with no change to the queue status.

Once the queue was cleared each email address was tested with seeveral emails to it. One at a time each address was tested and 4 of the mailboxes were discovered to not be accepting the mail. Still no error to refer to though.

The 'faulty' mailboxes were backed up, deleted from exchange and a new mailbox setup for the 4 users. Once done all mail was imported back and everything was working.

I'm not entirely sure why this happened but just glad it's out of the way.

Another solution would have been to roll back to a previous date. (should have done this sooner)

Thank you for your assistance.
0
 

Author Closing Comment

by:gerard_thusa
ID: 35221374
Details in post.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question