Solved

Microsoft ISA 2006 Blocking files from SharePoint.

Posted on 2011-03-16
7
538 Views
Last Modified: 2012-05-11
External users are unable to open documents from SharePoint, When a document is opened SharePoint asks for authentication and then loads the ISA connection screen in a word document.
I have attached the screen shot of this error.
If an external user users a VPN and then loads SharePoint everything loads ok. I believe this is a problem with ISA blocking connections to SharePoint. When setting up ISA I used a standard SharePoint publishing rule with no SSL.
Everything else works fine but opening documents.  

Sharepoint-problems1.xlsx
0
Comment
Question by:DanJEvans
  • 5
  • 2
7 Comments
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 35148150
Do you enable link translation on publish rule ?
0
 

Author Comment

by:DanJEvans
ID: 35148545
Yes this is enabled. Http:\/\/example.com to http:\/\/example.com
0
 

Accepted Solution

by:
DanJEvans earned 0 total points
ID: 35149865
I have managed to solve this problem; it seems that the fault was with office 2010 and basic authentication. Apparently office 2010 does not support basic authentication with SharePoint so I have added the following registry key and its now working fine.  

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet, add a  DWORD called  BasicAuthLevel with a value = 2

 
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:DanJEvans
ID: 35149900
I have managed to solve this problem; it seems that the fault was with office 2010 and basic authentication. Apparently office 2010 does not support basic authentication with SharePoint so I have added the following registry key and its now working fine.  

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet, add a  DWORD called  BasicAuthLevel with a value = 2
0
 

Author Comment

by:DanJEvans
ID: 35152122
sorted
0
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 35152452
Glad to hear that...

Thanks for sharing.
0
 

Author Closing Comment

by:DanJEvans
ID: 35178791
This is now working fine.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Summary In SharePoint 2010 it is easy to create custom color themes to jazz up a site. Theme colors can also be created in PowerPoint 2010 with a few clicks. But how do the chosen colors actually look in the SharePoint site? The attached PowerPoint…
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now