Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 956
  • Last Modified:

Sharepoint - Read only users but needs to access to create a view of the data.

Several document libraries that we have created in SharePoint 2010 that are read-only however we want to be able to give people access to create their own views of the document library however that option to create a view is not available.   If I move a user to contribute rights then they do have the ability to create a view however this can not happen for these libraries and lists.

Any workarounds?

0
MainSail2007
Asked:
MainSail2007
  • 3
  • 3
1 Solution
 
psv1973Commented:
In the list settings you can allow people to create personal views. i.e. views that are not visible to other people.


From the article below:
You can create personal views and public views. A personal view is available only to you when you look at a list or library. A public view is available when anyone looks at a list or library. To create a public view, you must have permission to change the design of the list or library. You can make a public view the default view for a list or library.




http://office.microsoft.com/en-us/windows-sharepoint-services-help/create-or-change-a-view-HA010021577.aspx

0
 
MainSail2007Author Commented:
psv1973 thank you for the information but when I tested this it does not seem to work for read-only users even if I gve them those options
0
 
sharepointguru14Commented:
you need to create a custom permission level. You can do this by going to site actions --> site settings--> site permissions and then in the ribbon selecting permission levels. Once there click add a permission level and you can create a new permission level by naming it and selecting granular permissions of what that level can do. You would want to select the read only permissions that you are already granting but you also want to scroll down to the bottom and select Manage personal views under the personal permissions section.

Let me know if you have any questions.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
MainSail2007Author Commented:
Thanks
I created a new custom level with the following permissions
VIEW Items
OPEN Items
VIEW Version
CREATE Alerts
VIEW Application Pages
VIEW Pages
BROWSE User Information
USE Client Integration Features
OPEN
and then I selected all three under personal permissions

This is SharePoint 2010 Foundation :)
Thanks
0
 
sharepointguru14Commented:
OK then grant that group or users access for that new permission level and you should be all set.
0
 
MainSail2007Author Commented:
that is what we did setup and still do not have access to create views.  
0
 
sharepointguru14Commented:
what is the error if you selected the 3 permissions under personal permissions one of them is allow creation of personal views so....That one should allow you to create your own view. But it is important that we confirm that the user is in that custom permission group and not in something more restrictive that would deny it
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now