• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 982
  • Last Modified:

Nslookup reveals wrong information

I have an Exchange 2007 server.

When I do a NSLOOKUP and set type=MX, I do not get a Non-authoritative response.

Below is what I get.

> set type=mx
> abcmymail.com
Server:  abc.mydomain.local
Address:  192.168.0.2

abcmymail.com
        primary name server = abc.mydomain.local
        responsible mail addr = hostmaster.mydomain.local
        serial  = 19
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)

Help!
0
EndUser
Asked:
EndUser
1 Solution
 
rjmarderCommented:
It looks like you are using your internal DNS server to perform the lookup. Try setting an external DNS server and you should get the Non-Authorative response your looking for.

Example:
nslookup

> server 4.2.2.2
Default Server:  vnsc-bak.sys.gtei.net
Address:  4.2.2.2

> set type=mx
> abcmymail.com
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now