Solved

Problem SSH connection with ESX 4.1.0 348481 UPDATE 1 - URGENT !!

Posted on 2011-03-16
8
2,039 Views
Last Modified: 2012-05-11
We have two ESX vSphere structures:

structure "A" -> with a vSphere 4.0.1
structure "B" -> with ESX version 4.1.0, 348481 UPDATE 1 (latest version available today)

We use Veeam Backup & Replication v.5 for backups of VM

- in the structure "A" I don't have problem
- in the structure "B" the phisical HOSTS don't see the physical storage connected to ESX (fiber channel and iSCSI).

In the structure "B" we have enabled the following:

1) Local TSM enable (see attachment "Structure B - Local TSM enable.jpg")
2) Remote TSM enable SSH  (see attachment "Structure B - Remote TSM SSH enable.jpg")

In the structure "B", I think that the problem may be with communication in SSH.
For example: if I use SSH with putty, I enter in the host but I can not see the folder as the "ssh", which should be inside the folder "etc"  (see attachment "new host - no show folder SSH.pdf")

In the old structure "A" attached, you see attachment "old host - show folder SSH - ok.jpg"
So, in I also notice that the prompt is "root@...", in the new structure "B" is different, but I use always the root account.

If I use Veeam also in the structure "A" (Structure A - show SSH connection TAG.jpg) appears TAG SSH connection, while in structure "B" this does not appear (Structure B - don't show SSH connection TAG.jpg)

I do not think is a problem of Veeam, I think it is a problem of physical configuration of ESX.

Is very urgent.

Thanks
new-host---no-show-folder-SSH.jpg
old-host---show-folder-SSH---ok.jpg
Structure-A---show-SSH-connectio.jpg
Structure-B---don-t-show-SSH-con.jpg
Structure-B---Local-TSM-enable.jpg
Structure-B---Remote-TSM-SSH-ena.jpg
0
Comment
Question by:Andrea Chiavegato
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 16

Expert Comment

by:danm66
ID: 35150216
If you are saying that the ESX 4.1 hosts or the physical backup host can't see the iSCSI or FC storage, then the issue isn't with SSH... it's probably a problem with zoning or presentation of the LUN's from the SAN to the host(s).
0
 

Author Comment

by:Andrea Chiavegato
ID: 35150340
No, the hosts see the storage Fibre Channel and iSCSI VM working properly and regularly.
When I use Veeam Backup or FAST SCP (which uses SSH API of VMWare) I can not do the backup on storage. This is why I did not request any authentication but only SSH authentication SOAP.

 Thanks
0
 
LVL 8

Expert Comment

by:PenguinN
ID: 35150435
1.) Go and edit the /etc/inetd.conf file type : vi /etc/inetd.conf
2.) Uncomment the line where you can see “#ssh” (line 32). Remove the “#” mark at the beginning.
3.) Then press ESC and type in :wq!
4.) Then run the command /sbin/services.sh restart

Source: http://www.vmug.nl/modules.php?name=Forums&file=viewtopic&t=5288

That should do the trick, also check if root has access.
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 
LVL 16

Expert Comment

by:danm66
ID: 35150503
Is this the "free" version of ESXi?
0
 

Author Comment

by:Andrea Chiavegato
ID: 35150697
No, is the enterprise PLUS.
thanks
0
 

Author Comment

by:Andrea Chiavegato
ID: 35152334
for "PenguinN" - in the file the "#" is not present - see the attachment.

do you have an another idea ?
file-inetd.conf.jpg
0
 
LVL 7

Accepted Solution

by:
jackiechen858 earned 250 total points
ID: 35153709
From your screenshot, You are using ESXi 4.1 not ESX4.1.



ESXi only has a "Tech Support Mode", not full SSHD, so probably there is no /etc/ssh/ folder at all.

check this http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1017910
0
 
LVL 1

Assisted Solution

by:cdrivedave
cdrivedave earned 250 total points
ID: 35208942
ESXi uses 'dropbear' as the SSH server, which stores its host keys in

/etc/dropbear/dropbear_dss_host_key
and
/etc/dropbear/dropbear_rsa_host_key

There's nothing wrong with the ESXi installation; it's just a different version of the software. ESX is based on redhat and is very 'heavy' compared to ESXi, which is based on busybox and is very 'light'. The file structure, binaries, etc are all completely different and ESX is now at end-of-development.
0

Featured Post

Plug and play, no additional software required!

The ATEN UE3310 USB3.1 Gen1 Extender Cable allows users to extend the distance between the computer and USB devices up to 10 m (33 ft). The UE3310 is a high-quality, cost-effective solution for professional environments such as hospitals, factories and business facilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question