Solved

Cisco 3550 Switches and NIC Teaming on Servers

Posted on 2011-03-16
17
555 Views
Last Modified: 2012-06-22
Tonight our server guys are installing a 4 port NIC card into one of their servers for NIC Teaming.  This network consists of three Cisco 3550-48 switches.  All three switches are all in the same VLAN.  Are there any special configurations needed on the switches that I would need to make to ensure their NIC teaming project is a success tonight?  I was reading alot of articles and they all said something different.  One article said their was a special configuration, the next article said as long as all the switches are in the same VLAN it will work fine.  Any assistance wouild be greatly appreciated.  Thanks.
0
Comment
Question by:denver218
  • 9
  • 8
17 Comments
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35151226
Depending on the NIC, you will most likely need to configure a port channel on the 3550 (type would definitely depend on what NIC) and the NC should have software with it for the teaming part.  This article should help you get going but you'll need to tweak it a bit depending on the NIC.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml
0
 
LVL 4

Author Comment

by:denver218
ID: 35151343
The type of NIC is an Intel, and they do have software to configure it.  I will take a look at the link.  Thanks.
0
 
LVL 4

Author Comment

by:denver218
ID: 35155569
Let's say I'm going to use ports fa0/1 - 4 on my cisco switch.  Can you show me an example of how these ports need to be configured.  Thanks.
0
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35155656
etherchannel or LACP?
0
 
LVL 4

Author Comment

by:denver218
ID: 35155808
I'm not sure.  Does this depend on the NIC card that they using?
0
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35155811
Yes.  Do you have the model of the NIC?
0
 
LVL 4

Author Comment

by:denver218
ID: 35155917
The NIC they now decided to use is a 4 port Broadcom BCM5709C NetXtreme II GigE.  Thanks.
0
 
LVL 1

Accepted Solution

by:
evan_weiner earned 500 total points
ID: 35157065
It'll be something similar to this...

interface Port-channel1
 description bundle
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
...
!
interface GigabitEthernet1/0/1
 description NIC1
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 channel-group 1 mode passive
!
interface GigabitEthernet2/0/1
 description NIC2
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 channel-group 1 mode passive
!

Depending on the requirements of the NIC, you may need to play with the channel-group mode under the physical interface.  Just do channel-group # mode ? to see the options although I think the Broadcom's will do LACP (the server connected to this example is a Broadcom).

You can also check the status -

VA-SPTC-Core-C3750#sh etherchanne
                Channel-group listing:
                ----------------------

Group: 1
----------
Group state = L2
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0

-Evan
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Expert Comment

by:evan_weiner
ID: 35157077
If it's all in VLAN1, you can omit the "switchport access vlan 20" part as the interfaces will default to VLAN1 or put in the appropriate VLAN number.
0
 
LVL 4

Author Comment

by:denver218
ID: 35157823
Okay, let me give it a try and see what happens.  My speed will be 100 not 1000 though cause this isn't a gigabit switch.  Thanks.  I'll let you know the outcome.
0
 
LVL 4

Author Comment

by:denver218
ID: 35165359
Things still are not working right.  I have 2 servers each has a 4 port NIC.  I configured the switch as above, but if I transfer a file between the two servers is only going at 10Mb.  I'm not sure what I'm doing wrong.  Any ideas?
0
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35172083
Can you post your switch config and screenshots from BACS?
0
 
LVL 4

Author Comment

by:denver218
ID: 35179771
Below are my switch configurations:  Thanks.

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LAN_SW1
!
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
interface Port-channel1
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast
!
interface Port-channel2
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet0/1
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/2
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/3
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/4
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/5
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/6
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/7
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/8
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/9
 switchport mode dynamic desirable
!
interface FastEthernet0/10
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
!
interface FastEthernet0/12
 switchport mode dynamic desirable
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
 switchport mode dynamic desirable
!
interface FastEthernet0/23
 switchport mode dynamic desirable
!
interface FastEthernet0/24
 switchport mode dynamic desirable
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 172.19.4.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end
0
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35179968
How about a sh log, sh etherchannel sum, and screenshot from the Broadcom config suite?  Did you configure the team in there?
0
 
LVL 4

Author Comment

by:denver218
ID: 35180452
Ok, below is the requested information.  Port channel 2 is the one that I currently have configured.  It consists of ports fa0/5 thru fa0/8.  Port Channel 1 is currently not being used at the moment because the server it down for maintenance.

Switch#show etherchannel
                Channel-group listing:
                ----------------------

Group: 1
----------
Group state = L2
Ports: 4   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP

Group: 2
----------
Group state = L2
Ports: 4   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP


Switch#show log
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes,
 0 overruns)
    Console logging: level debugging, 168 messages logged
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 168 messages logged
    Exception Logging: size (4096 bytes)
    File logging: disabled
    Trap logging: level informational, 172 message lines logged

Log Buffer (4096 bytes):
5:29:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, change
d state to up
05:29:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to up
05:29:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, chang
ed state to up
05:29:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, chang
ed state to up
05:32:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, chang
ed state to down
05:32:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, chang
ed state to down
05:32:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to down
05:32:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, chang
ed state to down
05:32:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, chang
ed state to up
05:32:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, chang
ed state to up
05:32:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, chang
ed state to up
05:32:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to up
05:32:59: %LINK-3-UPDOWN: Interface Port-channel2, changed state to up
05:33:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed
 state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed st
ate to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/6, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
2d20h: %LINK-3-UPDOWN: Interface Port-channel2, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/6, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to down
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/6, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/6, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to up
2d20h: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to up
Switch#2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to up
Switch#2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed
state to up
2d20h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed
state to up
Switch#

Attached are the Screen Shots.  As you can see if I go to the properties of the NIC Team it shows a speed of 400 Mbps so it looks like its working.
 screen-shots.docx
0
 
LVL 1

Expert Comment

by:evan_weiner
ID: 35181624
So let's back up a bit.  If you do a sh ether sum, does it list it as up? (something like SU after the interface name)?  Where are you trying to transfer files to - is it on the same switch, router between, etc?  Could there be some other factors limiting performance?  Is the other client attached to wireless?
0
 
LVL 4

Author Closing Comment

by:denver218
ID: 35261012
Thanks
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

This is about my first experience with programming Arduino.
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now