Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3481
  • Last Modified:

MSCONFIG and REGEDIT Opens in Notepad

I have a Windows XP machine that opens MSCONFIG and REGEDIT in notepad when executed. I ran Darik's Boot and Nuke on the machine, reinstalled Windows XP Professional w/SP3 and have installed the updates. I still have the same problem both in normal mode and in safe mode.
0
ttiefel1
Asked:
ttiefel1
  • 3
  • 3
  • 2
  • +1
3 Solutions
 
KPAYNE123Commented:
Download and run this script http://securityresponse.symantec.com...UnHookExec.inf which will reset your reg entries to default.

0
 
prashant_sawantCommented:
HAve you tried opening the reg from c:\windows\regedit.exe. If not please try and let us know.

As per you, u have reinstalled the OS, But what have caused you to reinstall, was the machine afftected with VIRUS.
0
 
speshalystCommented:
Open a command prompt and run
"reg query HKCR\regedit\shell\open\command"

On my machine where Regedit works as it should .. the result shows..

HKEY_CLASSES_ROOT\regedit\shell\open\command
    <NO NAME>   REG_SZ  regedit.exe %1

verify if you get the same output ..
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
speshalystCommented:
Also .. if you open some folder.. go to Tool>Folder Options>File Types ..
you should see a whole list of registtered file type..

scroll down the list and look for REG ... and highlight it .. the bottom half of that window should show the associated executable as "Open with Registry Editor" .. if this looks different on ur machine..

click on the change button and point to the "Regedit.exe" as the default file association.
0
 
ttiefel1Author Commented:
Yes, I had a virus on the computer prompting me to run Boot & Nuke. I tried all solutions:

KPAYNE123:  I didn't have the option to install the .inf when I right-clicked on the file.

prashant_sawant: - when I tried to run regedit.exe in the Windows directory it still opened with notepad.

speshalyst - When I ran reg query I received the same results as youi. However, I had no Folder Options under the Tools.
0
 
speshalystCommented:
"However, I had no Folder Options under the Tools. " - Don't you see this Menu option when you open any folder on you machine ??
0
 
KPAYNE123Commented:
To enable the Install command for .inf files, use any one of the following methods:

NOTE: For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

Change the "(Default)" value in the HKEY_CLASSES_ROOT\.inf registry key to inffile. Restart your computer for this change to take effect.
Restore the standard shell commands. To do so, click the Start button, click Run, type the following line in the Open box, and then click OK:

rundll setupx.dll,InstallHinfSection DefaultInstall 132 c:\windows\inf\shell.inf

NOTE: Type the above line as one long line. If you installed Windows 95 in a folder other than the Windows folder, adjust the command accordingly.

After hard disk activity stops, restart Windows.

Start Windows Explorer.
On the View menu, click Options, and then click the File Types tab.
In the Registered File Types box, click Setup Information, and then click Edit.
Click New, type Install in the Action box, and then type the following line in the Application Used To Perform Action box:

c:\windows\rundll.exe setupx.dll,InstallHinfSection DefaultInstall 132

NOTE: Type the above line as one long line. If you installed Windows in a folder other than the Windows folder, adjust the command accordingly.
Click OK Until you return to Windows Explorer.

If "Setup Information" does not appear in the Registered File Types box a new one must be made. To make a new "Setup Information" File type:

Delete the .inf key in the following registry key:

HKEY_CLASSES_ROOT
Start Windows Explorer, click Options on the View menu, and then click the File Types tab.
In the Registered File Types box, click Setup Information, and then click Edit.
Click New, type &Install in the Action box, and then type the following line in the Application Used To Perform Action box:

c:\windows\rundll.exe setupx.dll,InstallHinfSection DefaultInstall 132

Click New, type Open in the Action box, and then type the following line in the Application Used To Perform Action box:

c:\windows\notepad.exe

Click New, type Print in the Action box, and then type the following line in the Application Used To Perform Action box:

c:\windows\notepad.exe /p

Click OK, and then click Close.
0
 
ttiefel1Author Commented:
There is no Menu option under Tools for folders
0
 
ttiefel1Author Commented:
Gentlemen thanks for your solutions. I accepted all your solutions because I tracked down the problem to corrupted data on our WSUS server. I reinstalled WinXP and downloaded the updates from Microsoft and everything was fine.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now