Go Premium for a chance to win a PS4. Enter to Win


Why am I getting "Arguments are of the wrong type, are out of acceptable range, or are in conflict with one another."

Posted on 2011-03-16
Medium Priority
Last Modified: 2012-05-11
I am using classic ASP to access records on an Oracle database.

The connection string I am using works with other tables on the database with no issues.

If I comment out the RS4 portion of this code the page runs fine and displays the other values...just not the tech values.

The database guy I am working with says he gets records returned while using Microsoft Query. I've even changed the query to a basic form of "select this from that" and still the same error.

When I run this part of the code (attached) I get:

ADODB.Recordset (0x800A0BB9)
Arguments are of the wrong type, are out of acceptable range, or are in conflict with one another.
/web/report.asp, line 378

with line 378 being:

RS4.OPEN sqlTechQry, oConnMTV, 3,3

I'm not sure if there is an issue with the database connection string or something else. The attached code has the oracle connection string I am using and the code.

Any help would be appreciated. Document1.txt
Question by:Donnie Walker
  • 3
  • 2
  • 2
LVL 14

Expert Comment

ID: 35152798
Can you print the query in HTML page before RS4.OPEN


RS4.OPEN sqlTechQry, oConnMTV,3,3

Author Comment

by:Donnie Walker
ID: 35153161
I get this error:

Microsoft VBScript runtime (0x800A01B6)
Object doesn't support this property or method: 'debug.print'

But I have printed out the query and confirmed it does work with Microsoft Query.
LVL 14

Expert Comment

ID: 35153184
May be you need to debug little more

Here are the steps to debug


Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 34

Expert Comment

by:Big Monty
ID: 35156780
i would change your rs4.open statement to:

set RS4 = oConnMTV.Execute( sqlTechQry )

since you're not updating the recordset, it's better (performance-wise) to do it this way.

Author Comment

by:Donnie Walker
ID: 35157363
When I do that I get this error:

Microsoft OLE DB Provider for Oracle (0x80040E0C)
Command text was not set for the command object.
LVL 34

Accepted Solution

Big Monty earned 2000 total points
ID: 35157520
this usually indictaes something wrong with the query. can you test out a simple select statement using the syntax I provided, just so we can debug it further?

Author Closing Comment

by:Donnie Walker
ID: 35227205
Thanks! Your suggestion led me to examine my code and I discovered I was calling a function inside a larger function and that was causing the error.

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction A previously published article on Experts Exchange ("Joins in Oracle", http://www.experts-exchange.com/Database/Oracle/A_8249-Joins-in-Oracle.html) makes a statement about "Oracle proprietary" joins and mixes the join syntax with gen…
This post first appeared at Oracleinaction  (http://oracleinaction.com/undo-and-redo-in-oracle/)by Anju Garg (Myself). I  will demonstrate that undo for DML’s is stored both in undo tablespace and online redo logs. Then, we will analyze the reaso…
This video shows how to Export data from an Oracle database using the Original Export Utility.  The corresponding Import utility, which works the same way is referenced, but not demonstrated.
This video shows how to copy an entire tablespace from one database to another database using Transportable Tablespace functionality.
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question