Solved

FTP Server Problem, clients getting disconnected

Posted on 2011-03-16
8
406 Views
Last Modified: 2012-06-22
Hello,

I'm running a FTP server on my Windows Server 2008 R2, using Filezilla Server to manage accounts.  I've had zero problems using it as a client, and most of our clients have no issues either.  But it seems like our more "corporate" clients tend to have connectivity problems, where they can't access it at all or can start downloads that get interrupted.  I'm guessing this is because of the IT infrastructure of the offices that they are working in, and some sort of firewall issues.

I'm a developer not a sys admin, so I'm at a loss here.  I don't know what to tell this client who insists it's been very problematic.  Do you have any advise as to what some general issues may be.  Thanks,

Justin
0
Comment
Question by:JT_SIRO
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 11

Expert Comment

by:wrmichael
ID: 35151973
we switched to a web based product from IPSWITCH for the same reasons.

you just have to get their IT staff involved to help track down what part of the network is blocking it.
0
 
LVL 4

Accepted Solution

by:
cavp76 earned 63 total points
ID: 35152131
First: make sure their clients are configured to use passive mode. Second: if possible, that they open outbound port 20 in their firewall.
0
 
LVL 16

Assisted Solution

by:AlexPace
AlexPace earned 62 total points
ID: 35152133
Your server software may allow you to specify a range of ports to be used for passive mode file transfers.  Choose a range (# > 1024) that contains at least as many ports as the maximum number of simultaneous client connections then make the range 50% bigger to support future growth.

Now when you are telling people how to connect to your server make sure to tell  them your passive data channel range.  This will allow them to poke holes in their firewall that matches your range.  Their IT staff can get all difficult if you don't restrain the port range because having a lot of open ports keeps them up at night.
0
 
LVL 38

Assisted Solution

by:Aaron Tomosky
Aaron Tomosky earned 125 total points
ID: 35152270
I also use filezilla for the same stuff. I setup both active and passive connections to allow for anyone to connect. The only people that have issues now are ones that try to use the FTP built into their browsers. Is this what you are seeing?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:JT_SIRO
ID: 35152514
Thanks for the all the advise so far.  I don't really understand the whole passive ports thing, but I think I should be fine.  I checked my settings, they're set to "Use custom port range:" 3850 - 3859.  And I never have more than 2-3 clients on simultaneously.

Another thing to mention is that this server is within my companies network and firewall.  Their admin gave me port 2121 to access it from an FTP client.  So I require all clients to enter port 2121 when they log in.  Does this restrict what I can do?  Does that mean that only one client can access it?  
0
 
LVL 16

Expert Comment

by:AlexPace
ID: 35152553
Lots of clients access a web server on port 80.  It sounds like you are doing the right things but at some point if you want to help the clients you'll need them to provide you with logs that show protocol-level tracing so you can see what they were actually trying to do when they disconnected.  You could look in your logs too but unless they only connect once per day you'll need to know the exact time of the connection and failure or risk wasting a bunch of time looking for a needle in a haystack.
0
 

Author Comment

by:JT_SIRO
ID: 35152581
Another thing I just noticed is that "Block Server to Server Transfers" WAS checked.  I unchecked it.

I'm guessing that could be why some of my more corporate clients have experienced problems from their offices, but were fine at home.  Thoughts?
0
 
LVL 38

Assisted Solution

by:Aaron Tomosky
Aaron Tomosky earned 125 total points
ID: 35152775
Widen your port range. By default filezilla clients and other clients use up to 10 connections at a time. This will require a change in your router as well. I use a 100 wide range personally
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Excessive tcp resends from my ASA 7 30
NSD FAIL 2 24
ipsec tunnel comme not up 10 25
Cisco IOS from ipbase to ipservices 10 27
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now