?
Solved

Disable autodiscover

Posted on 2011-03-16
11
Medium Priority
?
960 Views
Last Modified: 2012-05-11
Most of my client doesn't host their own email and they are only small businesses which I
don't find any use of autodiscover.  How can I disable this even temporarily.  I found one and it
is successfull but comments below says that it is not good to stop the autodiscover app pool.
My main concern is that the outlook 2007 is keeps on asking for credential which doesn't accept
even the input info is right.  In order to get the right @email address I need to run the wizard
which automatically creates remote.???.com which doesn't exist at all.  I'm using only the exchange
as a data storage and contacts, mailbox, calendar sharing.  Is there a proper way to do this.  Search
in Google and it seems microsoft doesn't have an answer. I was able to do it before with one of
my client but unfortunately I can't remember it anymore.  Any help will be greatly appreciated.  
0
Comment
Question by:cdmgs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
11 Comments
 
LVL 74

Accepted Solution

by:
Glen Knight earned 2000 total points
ID: 35152254
Simple answer is you can't, it's used for Offline Address Book & Free/Busy Information, it's also built in to Outlook 2007 and 2010 so if you could disable it on the server you can't disable it on the clients.

I have an article for the password prompting issue with SBS2008: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html
0
 
LVL 7

Expert Comment

by:brota
ID: 35152381
you can change the autodiscover scp point to an invalid url so they wont be able to access it.

if you do a get-clientaccessserver | fl you can see the value.
you will need to manually configure outlook if you do this.
you can also change the EWS url too.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35152430
@brota - You can't simply point Autodiscover to an invalid URL - it will cause all manner of problems.  You also can't disable it.  You have to learn to live with it!

Demazter's comment is spot on and his article advises several ways to resolve the password prompt issue.  You would do well to read it and stop posting information that is not remotely helpful.

Alan
0
2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

 
LVL 7

Expert Comment

by:brota
ID: 35152489
I did not copy and paste from somone I had this in my email for months from a co-worker
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35152501
@Brota - Please do not post blind links to something you have Googled.  Please add some additional information about what can be found at the link and describe in your own words what the link is about.

If the link fails in the future and the solution is accepted as the solution to the question on EE, then the solution is valueless.

Please re-post your link with some additional text and refrain from simply posting just a link in a question in future.

Many thanks

Alan Hardisty
EE Zone Advisor
0
 

Author Comment

by:cdmgs
ID: 35153619
Finally I was able to solve my problem without installing SP2 or SP3 in exchange or stopping the Autidiscover apps pool.  I have done this before but cannot remember how I did it. Here what I have done which is all about IIS:

Under SBS Web Applications:

Click Authentication icon and check the settings. Basic and Windows authentication should be enable and under advance settings of windows authentication  the kernel-mode authenticarion should be enable or tick mark

Autodiscover
EWS
OAB
RPC
RPCwithCert

Windows authentication should be enable and under advance settings of window authentication,  the kernel-mode authentication also must be enabled

Unified Messaging


Thanks anyways for the help and feedbacks.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35154349
That's covered in the article posted by Demazter (his own article) in the first comment of this question.
0
 

Author Comment

by:cdmgs
ID: 35156037
Yes it is!  Before I tried this expert exchange I already tried this solution that came from other source and same thing I followed the solution but no go. One thing they forgot to mention is the the basic and wndows authentication should be enabled and I think rpcwithcert and UM should be included in the solution.  Will verify once a got a freshlyh installed SBS2008 and check what defaults that it gives before fixing the issue. I already done this to all my clients long time ago but can't remember this time.
0
 

Author Closing Comment

by:cdmgs
ID: 35247011
One thing they forgot to mention is the the basic and wndows authentication should be enabled and I think rpcwithcert and UM should be included in the solution
0

Featured Post

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read about achieving the basic levels of HRIS security in the workplace.
Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question