• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2230
  • Last Modified:

RHEL 6 and WebSphere Message Broker install

I installed RHEL 6, and then isntalled WMB, and got the following warning:

Press 1 for Next, 2 for Previous, 3 to Cancel or 4 to Redisplay [1] 1

Installing IBM WebSphere Message Broker 7.0. Please wait...


|-----------|-----------|-----------|------------|
0%         25%         50%         75%        100%
|||||||||||||||||||||||||||||||||||||||||||||||||

Creating WorkPath...
Warning: UNIXProcess.forkAndExec native error: No such file or directory

Please wait...

-------------------------------------------------------------------------------
The InstallShield Wizard has successfully installed IBM WebSphere Message
Broker 7.0. Choose Finish to exit the wizard.

Press 3 to Finish or 4 to Redisplay [3]

Open in new window


Hoping the warning is not significant, I create a broker:

bash-4.1$ pwd
/opt/ibm/mqsi/7.0/bin
bash-4.1$ whoami
mqm
bash-4.1$ . ./mqsiprofile

MQSI 7.0.0.1
/opt/ibm/mqsi/7.0

bash-4.1$ ./mqsicreatebroker LINUXQM -q LINUXQM
(LINUXQM.mqsicreatebroker)[1]BIP2229W: Warning: abend file directory (/var/mqsi/common/errors) open failed: errno 2. Using directory /tmp 0
Failed to open file /var/mqsi/common/log/LINUXQM.mqsicreatebroker.trace.bin.0 with error No such file or directory
Failed to open file /var/mqsi/common/log/LINUXQM.mqsicreatebroker.userTrace.bin.0 with error No such file or directory
BIP8011E: Unable to create the components configuration data.
The command is unable to store the component's configuration data.
Ensure that the userid that is running this command has adequate authority to update the configuration or registry files. Without this authority the registry or configuration files cannot be updated.  Also check that the broker name does not contain invalid characters or is too long.

Open in new window


I have adequite permission (su mqm), but the directory is not there:

bash-4.1$ cd /var/mqsi
bash-4.1$ cd common
bash: cd: common: No such file or directory
bash-4.1$ ls
install.properties

Open in new window


Is there a Linux package I need to install, or some other issue ?

Any ideas how I can resolve this ?
0
Los Angeles1
Asked:
Los Angeles1
1 Solution
 
paulqnaCommented:
I suggest you create these directories manually (with 777 permissions to be safe for initial testing) as a workaround?:

/var/mqsi/brokers
/var/mqsi/common
/var/mqsi/components
/var/mqsi/registry

and then try to create a broker again?
0
 
Los Angeles1Author Commented:
It works.

I also had to create /var/mqsi/commmon/log

Also found out that WMB 7.0.0.2 isupports RHEL 6, but not WMB 7.0.0.1

http://www-01.ibm.com/support/docview.wss?rs=849&uid=swg27017129
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now