Incoming Remote Desktop cannot connect using IPv4, only IPv6 - Windows 7 Pro x64

I have a Windows 7 x64 Professional PC that is set to allow incoming remote desktop connections. Until a few days ago this was working perfectly, but without warning it has started to refuse connections that are targeted at its IPv4 address - the system attempting to establish the connection just times out. The system is not set to require NLA.

Bizarrely, when using the IPv6 address, it accepts the connection and works normally.

I have verified that all the services are running, and that it is listening on port 3389 (both IPv4 and v6), and have tested without any firewall turned on - same result. Since the problem manifested, I have installed Win 7 service pack 1, which has made no difference. All other incoming IPv4 connections are accepted normally (file sharing, TFTP, etc).


Please advise the next steps I should take to troubleshoot this. Thanks in advance.
sam_gcausAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ded9Connect With a Mentor Commented:
Do clean boot

Clean Boot Process
Click Start-msconfig-click on services tab -put a check on hide all microsoft services and then click disable add. Click on startup tab and disable all.

Restart the computer.

Now check. Post the results


Ded9
0
 
sam_gcausAuthor Commented:
This pointed me in the right direction and allowed me to pinpoint the cause of the issue.
0
 
sam_gcausAuthor Commented:
Thanks ded9. RDP worked fine using the IPv4 address with all startup items and services disabled. It actually turned out to be our Trend Micro WFBS personal firewall. It should actually be disabled, as I use the Windows 7 built-in firewall, so the real issue is that the settings specified on the Trend server are not applying to the client properly, which I'll investigate as a seperate issue.

Thanks again!
0
All Courses

From novice to tech pro — start learning today.