SBS 2008 Backup Usb Hard drive


I manage an SBS2008 server, for about a year now the backup process to two usb hard drives has been working just fine. Just over a month ago, the server failed to recognize backup drive 2. I replaced this drive with another and all was OK, until this week when Backup drive 2 failed.

The funny thing is that i can take the drive to another xp pc in the office and it is detected and can see the contents on it.  I deleted the partition and reformatted the drive but the server backup process wont see the drive.  I can see the drive in Device Manager but not under the Disk Management ??? hence the server doesn't see the drive.

I connected another new usb drive and added it to the backup process, no problems at all.

It is just weird that the suspect drive works in other pc's just fine.

My solution is that i am getting another 2 new usb drives to replace the originals, rather than mess around for ages looking for a solution why. But if anyone has any solutions then they will be appreciated.

Regards, Richard
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Did you try to plug in the USB hard drive to another port(which associate with another USB controller)?
Some time the problem happens on the USB controller from the server...
richrdh18Author Commented:
Yes tried that on both occasions in the rear usb ports
how about test it with the front usb port(if any)?  
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

richrdh18Author Commented:
Yep, tested on several rear and both front usb ports.
What's the server model/motherboard model?  
Is all the USB drive come from the same model same brand?
richrdh18Author Commented:
Hp ML 110 G6
Adata 250GB Usb hdd, both the same  

my thoughts are that the server is altering the mbr on the usb hdd, somehow ??
more likely is the usb drive issue, they''re not the same...  You may want to try another brand for it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
richrdh18Author Commented:
Just to add to a solution that worked for me for this error again, "backup failed as no target could be found"

A couple of months ago i replaced the old backup drives with two new ones.  Backup been working fine until this week when the same problem started happening again.

My solution, retarted the server with the backup drive still attached, after that i checked and could see the backup hdd under disc management, and it showed up as active again in the backup windows.

Will see how long it lasts for this time.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.