Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cannot access shared drive on network running Windows 7 OS

Posted on 2011-03-16
12
Medium Priority
?
945 Views
Last Modified: 2012-05-11
Hello Again Experts -

I have two computers on a home network. Each has been configured so that their respective drives C are available to everyone else on the netwok as "SharedC".

But, when I go into either comoputer trying to get access to drive on the other computer, I get the message:


"Network Error

Windows cannot access \\GORDON-PC\SharedC

You do not have permission to access \\GORDON-PC\SharedC. Contact your network administrator to request access."


Well, I am the administrator. About the only place where I am in charge in this life.

I have setup the sharing of each drive with full access rights to eveyone. Then, I went into the Control Panel and changed the advanced sharing settings so that I "Turned on file and printer sharing". In otherwords, I think that I have done everything correctly, but access is still denied.

Any idea of what is going on here?
0
Comment
Question by:gbmcneil
  • 7
  • 2
  • 2
  • +1
12 Comments
 
LVL 8

Expert Comment

by:andoss
ID: 35153850
Can you access any files or folders on the other machines?

Remember you need to setup the security under both the 'Sharing' and the 'Security' tabs.
Sharing is for the share permissions which Security is the NTFS permissions.

Also are the machines a member of the same HomeGroup? Did you create a HomeGroup?
0
 

Author Comment

by:gbmcneil
ID: 35153861
Hello andoss -

Thanks for responding. Give me a chance to get answers to your questions. I'll be right back!
0
 

Author Comment

by:gbmcneil
ID: 35153916
Okay. Here is what I've got. Let's talk about Computer1 trying to gain access to drice C on Computer2. The problem exists both ways, but it get's confusing if we try to tackle the problem on all machines at sametime.

Computer1 can "see" two shares on Computer2. The first one is a public area in the Users subdirectory. I can actually bring text files there into my text editor on Computer1. Then second share is the entirety of drive C on Computer 2.

I can't touch the second area. I can see it, but not access it. When I try to access it, I get an error message.

The network must be working or else I woudn't be able to see the "shares", and I wouldn't be able to read the text file in my editor.

So, something is missing here. Both are Windows 7 machines. I used to do this without a problem when my computers were running XP and I didn't do both "sharing" and "security" settings.

Any thoughts?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:gbmcneil
ID: 35153949
It is almost 2:00 AM here in Boston. I'm going to get some sleep. Talk to you in the morning.
0
 
LVL 8

Accepted Solution

by:
andoss earned 500 total points
ID: 35153957
On computer 2 right click C: Drive go Properties and the Security tab. Add the 'Everyone' group and give it atleast Read access then try to access the share from Computer1 again.

Does that work?

If you want things to be more secure then you need to create a HomeGroup.
0
 

Author Comment

by:gbmcneil
ID: 35153975
I am not trying to make things more secure. I'm trying to make access to each computer wide open.

I'll look at the Securities tab again, but I specifically made access open to everyone - and for reading, writing, deleting, whatever.
0
 
LVL 5

Expert Comment

by:NotVeryFat
ID: 35155081
Can you access the default c drive share (\\PCname\c$)?

If not, I found the following fixed issues mapping FROM a Windows 7 PC to another PC, but not sure whether it will fix Windows 7 to Windows 7. Possibly worth giving it a try:

Start -> Run -> secpol.msc.
Local policies -> Security Options
Network Security:LAN Manager authentication level, change to 'Send LM & NLTM - use NTLMv2 session security if negotiated'

(Make a note of what it was before you change, and then change back if it doesn't solve it after a restart.)
0
 
LVL 5

Expert Comment

by:NotVeryFat
ID: 35155099
Also, is the administrator password the same for both PCs? If not, set them the same and see if you can then map across as administrator.
0
 
LVL 1

Expert Comment

by:mgroover
ID: 35156146
Which version of Windows 7 are you running?
0
 

Author Comment

by:gbmcneil
ID: 35156881
I am up and at 'em.

Let me itemize for you the three areas of security that I have reset:

1. In the Network and Sharing Center of the Control Panel I have turned on "file and printer sharing", "public-folder sharing", and "40 or 56-bit encryption", and turned off "password protected sharing".

2. In My Computer, Local Drive C:\ Properties I have changed Sharing \ Advanced Sharing by naming the shared C;\ root directory "SharedC", and changed the Group or User names to "Everyone" and allowed "Full Control", "Change", and "Read". I did not re-set anything to do with "Caching".

3. In My Computer, Local Drive C:\ Properties I have changed  the Group or user names for:
                Authenticated Users
               SYSTEM
               Administrators (Gordon-PC\Administrators)
               Users (Gordon-PC\Users)
so that for each of these categories, I allow the maximum level of control
               
0
 

Author Comment

by:gbmcneil
ID: 35157027
Then I rebooted.I should report that in the process of doing all of the above, I got an error message:


Error Applying Security

An error occured while applying security information to:

c:\hiberfil.sys

The process cannot access the file because it is being used by another process.


Then it separately stops in its tracks to announce various subdirectories like C:\Program Files and C:\Windows.

It seems like it is giving authorization to access each file.

Then, when I have tred to access SharedC from Computer1 after a reboot, there is a progress bar that runs at the top of the dialogbox - as if it is engaged in checking the status of each one of the files in SharedC.

I don't know what the heck is going on here!
0
 

Author Closing Comment

by:gbmcneil
ID: 35160263
And, then I finally joined a "Homegroup" as suggested by andoss. That did the trick.

Actually I joined Homegroup on both Computer1 and Computer2.

Both C drives are now available no matter which computer I'm on.

Thanks many fold.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article helps those who get the 0xc004d307 error when trying to rearm (reset the license) Office 2013 in a Virtual Desktop Infrastructure (VDI) and/or those trying to prep the master image for Microsoft Key Management (KMS) activation. (i.e.- C…
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

876 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question