Solved

Cisco Port Configuration for NIC Teaming

Posted on 2011-03-17
8
681 Views
Last Modified: 2012-05-11
I'm going to setup NIC teaming on one of my servers.  I am going to install a intel 4 port NIC card in this server.  I want to use ports fa0/45, fa0/46, fa0/47, and fa0/48 on my Cisco 3550 switch.   I've looked over several documents from Cisco, but I'm still a little unsure.  I'm hoping someone can provide me with the configurations I will need for these four ports.  Below is the current configuration of my switch.  Thanks.

Current configuration : 4805 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch_1
!
!
no aaa new-model
ip subnet-zero
ip routing
!
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/10
switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/15
switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/25
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/26
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/27
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/28
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/29
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/30
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/31
 switchport access vlan 40
switchport mode access
!
interface FastEthernet0/32
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/33
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/34
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/35
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/36
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/37
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/38
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/39
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/40
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/41
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/42
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/43
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/44
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/45
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/46
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/47
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/48
switchport access vlan 40
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 192.168.1.3 255.255.255.0
!
interface Vlan20
 ip address 192.168.12.40 255.255.255.0
!
interface Vlan40
 ip address 10.4.0.1 255.255.0.0
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.12.200
ip route 0.0.0.0 0.0.0.0 192.168.12.201 10
ip http server
ip http secure-server
!
!
control-plane
!
!
l
!
end


0
Comment
Question by:Crossroads305
  • 4
  • 3
8 Comments
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 250 total points
ID: 35155619
Try something like:

interface Port-channel1
 switchport access vlan 40
 switchport mode access

interface FasttEthernet0/45  <-And 46, 47, 48
 switchport access vlan 40
 switchport mode access
 duplex full
 speed 100
 channel-group 1 mode desirable
 spanning-tree portfast trunk

0
 
LVL 1

Author Comment

by:Crossroads305
ID: 35155971
Thanks, I'll give this a try.  Will this work regardless of the type of 4 port NIC I am using?
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 35156014
That shouldn't matter. Though some type's have better teaming software than others.
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 1

Author Comment

by:Crossroads305
ID: 35156366
Does the "spanning-tree portfast trunk" have to be in the config?  Could this cause loops?
0
 
LVL 45

Assisted Solution

by:Craig Beck
Craig Beck earned 250 total points
ID: 35156478
spanning-tree portfast trunk is a command used when 802.1q capable NICs are connected to a switch.  Under normal circumstances you don't want portfast on trunk ports (typically for switch interconnects).  This option just tells the switch that the port should come up straight away.

No loop condition will occur if you configure your NIC teaming correctly.  Some teaming software may use different terminology, but you should use LACP (or 802.3ad) if you can.

As a note, I would probably change the line crossroads included above, as it implies a PAgP device (which is Cisco Proprietary)

channel-group 1 mode desirable
could be...

channel-group 1 mode passive

...which will enable LACP on the ports if an LACP device is detected.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 35156484
Nope. That means that (for example) when you reboot the server, the ports on the switch won't be put in hold-down but start forwarding immediately. You always add that when a computer/server is plugged in to a switchport and never add that when another switch or router is plugged in.
0
 
LVL 1

Author Closing Comment

by:Crossroads305
ID: 35159889
I ended up using
channel-group 1 mode passive

Thanks for your help.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 35159956
You're welcome, glad we could help.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
traffic flow without STP 9 52
Interface VLAN dependencies 6 50
HP Switches - Stacked to the max but need more ports, can I? 3 52
Non Distrubtive Core Switch Repacement 8 23
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
Microservice architecture adoption brings many advantages, but can add intricacy. Selecting the right orchestration tool is most important for business specific needs.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

775 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question